Announcement

Collapse
No announcement yet.

Abnormal battery drain after 10.0 firmware

Collapse
X
  • Time
  • Show
Clear All
new posts

  • Abnormal battery drain after 10.0 firmware

    After new firmware 10.0 the device battery consumption is about 20% per hour. Before with the same accessories connected was 10%/12%
    I used also firmware 9.34 before and no issues with that. What has changed from 9.34 to 10.0???

  • #2
    I’d Check that the back light is not on.
    Nick

    Comment


    • #3
      back light as before on Auto! As i told same accessories and settings but too much consumption...trying to disable bt and wi fi during activities!!

      Comment


      • #4
        I always have my backlight at zero brightness to maximise the battery life.
        Nick

        Comment


        • #5
          FWIW: My back light settings are Auto off, 50%, and 15 second time out. I can usually see the screen well enough during the day with the back light off, but if I can't, touching it will bring up the back light and make it readable. When it's dark, I'll usually leave the back light on at some very low level.

          Also, I have WIFI switched off. IDK how much that contributes to battery life.

          Comment


          • #6
            The WiFi automatically switches off when the timer is running.
            - Alan

            Comment


            • #7
              I had exactly the same problem. Battery went from 90% to 10% in 4 hours, so it is the 20% per hour you are talking about (backlight off, GPS only, navigation on). Also i experienced a very bad GPS reception, worst than 8.80, and obviously the grade was completely useless (showing 0% in the hardest uphill). I decided to make an hard reset. For now i used it just for indoor cycling and its consuption is about 5-6% per hour. I will test it outside soon and i will let you know.

              Comment


              • #8
                Since the first day I got 820 (a little more than 1 year now), I'm riding with 20% brightness, 30 sec backlight timeout, GPS+ Glonass and 3 sensors (speed, HRM and powermeter), phone not paired. In the past my battery life was fantastic, I could easily finish 200km brevets even with some navigation, and even managed to stretch it to almost 16 hours and finish 300 km brevet with few hours of navigation, so doing the maths, I'd say battery drain was about 5-6-7% per hour.
                I was very very satisfied and impressed with that, but things went worse when 5 months ago I had to replace that unit because Lap button got stuck so I got a new one with new warranty (not sure if actually new or refurbished tbh).
                First thing I noticed was that GPS signal wasn't that accurate like on the previous device but it got better eventually. What started bothering me lately, since the last few updates, is the battery life, I'm currently on FW 10.00 and losing about 9-10% per hour with all the settings like mentioned above, and didn't even try navigating; so I usually end a 3-3.5 hour ride with about 30% battery drained.
                Don't know what changed and why this happens but I find it really unacceptable after having that great battery life before because at this rate, I would barely be able to finish 200 km brevets, even without navigation!
                I was hoping after upgrading to 10.00 and after few rides thing would maybe become better, but no luck. I'm giving it few more days/weeks to see if it stays like this, but if nothing changes, and going to take it to my local Garmin shop once again.

                Comment


                • #9
                  I am seeing the same issues. Before the update, 9-10 hours with current settings (no backlight, running a power meter, radar, bluetooth running with live track). Seeing near 20% per hour. Got the 10% warning at 5.5 hours today. BS.

                  Also, batter save mode? Drops off GPS and most other things. That is insane. Cut the screen and bluetooth.

                  Comment

                  Working...
                  X