Announcement

Collapse
No announcement yet.

Battery drained while powered off.

Collapse
X
  • Time
  • Show
Clear All
new posts

  • #31
    So, here's my update. Garmin replaced my 820 because they thought I had a defective unit.

    So last week I tested it. I had it charged at the beginning of the week, and took it for my daily training rides (1 hour long). After each ride I noticed what the power level was, and pressed the power button to turn it off and left it in my desk at work.

    Worked fine first three days, power was down about 8% each ride.

    Thursday it wouldn't turn on at all, battery was at 0%.

    Comment


    • #32
      Hi,
      I think issue isn't in firmware itself,but in update procedure and settings conversion.
      I bought my Edge 820 with 6.50 and did updates each time when available. Up to 8.40 there was no battery issue even with Bluetooth and WiFi enabled and device in sleep mode.
      After update to 8.50 with BT and WiFi disabled battery was empty next day in the morning despite turning off device.
      I tried all settings described on forum and nothing helped.
      To confirm issue I was charging battery every day for one week.
      Two days ago I downloaded 8.40 and performed manual update.
      Issue solved.

      On 8.50 Edge didn't bip while turning off and required to tap turn off button twice.
      On 8.40 it works perfect again. Instant bip and Edge is switched off also instantly.
      Due to downgrade some settings were lost,but 3 minutes for adding sensors are worth of Edge working without battery issue again.

      I think I will try 8.50 again with reset to factory settings to check if this version can work normally.

      Comment


      • #33
        Lord - if you think the batt drain is bad on this product - try using my Garmin Virb....

        Comment


        • #34
          Just came to the site looking for issues with battery drain when switched off and it looks like a few people are having it. I'm fairly convinced this is related to the device freezing and not powering down properly. Probably one in every 5 times I shut the device down, the screen doesn't go completely blank. Then when I switch it on, it wont power up normally. I need to hold the power button down until it soft resets then power on again. I've had the battery down to 50% a few times after a full charge but this morning was the first time I had it go to 0%. This is my third replacement device from Garmin (for separate issues) so i'm fairly sure it's not a defective unit. All I can say is role on Hammerhead Karoo!

          Comment


          • #35
            indeed, I am quite agree with nik.taylor and think this is linked to this thread, edge820 not shutting off properly https://forums.garmin.com/forum/into...won-t-shut-off

            Comment


            • #36
              My Edge 820 was shutting off on all firmware versions I had recently: 6.50; 7.00; 8.00; 8.40; 8.50.
              After shut down logo disappeared in one second and screen was entirely blank ... still battery was empty after 24h.

              I tried again 8.50 with:

              Test_1:
              - Battery 100%
              - no data to synchronize - already synchronized through BT
              - BT disabled
              - WiFi disabled
              - GPS ready - no need to search for satellites
              - proper shut-down
              - 10 minutes later check again if screen is blank ... just to be sure there was no reset
              - 24h later empty battery

              Test_2:
              - reset to factory default
              - Battery 100%
              - BT off
              - WiFi off and no network added at all
              - No sensors added
              - Indor mode - no need to search for sattelites
              - proper shut-down
              - few minutes later check again if screen is blank
              - checking screen in every 2-3 hours during the day
              - 24h later empty battery

              I lost hope and I keep E820 connected to charger at night before planned ride.

              Comment


              • #37
                I was problem free... then I think there was an update end of Nov.
                Coincidentally, I also turned on the compass around the same time.

                I'm having this battery drain problem now, the last 2 days.

                Will see who the culprit is.

                Comment


                • #38
                  From my experience, you must shut down from the touch screen after pressing the power button on the side of the unit. If you rely on the power button, you'll end up with a dead battery every time. And the issue of having to shut off after charging the unit. Both of these issues have resulted in a dead battery prior to a ride.

                  Comment


                  • #39
                    I have reported the battery drain concerns and will post back if we need more information and to update status.
                    sigpic

                    Comment


                    • #40
                      So as per before, my 820 with firmware 8.70 drained 2 days in a row, which wasnt happening before the 8.50 -> 8.70 upgrade
                      or before I enabled the compass screen.

                      So yesterday, I did a soft reboot (ie power down for 10s) and disabled the compass.

                      Drain is no longer happening.

                      I might try the compass again some time later to see if that is the culprit but am happy
                      it is no longer happening.

                      Though I did receive an Elemnt for xmas. :-)

                      Comment


                      • #41
                        OK.. my 820 was dead again this morning. So the disabling the compass was a red herring. Maybe I had it powered off instead of it being on 'sleep'. Just checked my settings and auto-sleep was turned off. Am turning that on and will observe. Will try a hard reset as the last resort.

                        Comment


                        • #42
                          I'm pretty sure the 820 doesn't have a magnetic compass sensor. What you're enabling is screen that displays direction of travel based on changing GPS position, not magnetic heading. So enabling or disabling it is not turning on or off a piece of hardware that would drain the battery. That doesn't mean that enabling the compass doesn't do something else that affects battery drain.

                          Many phones do have a magnetic compass, but the 820 doesn't.

                          I'm the poster that originated this thread. I only had that one instance of battery drain while the unit was off and haven't experienced it since. My 820 is at 8.5 as I haven't yet updated to 8.7.

                          Comment

                          Working...
                          X