Announcement

Collapse

Forum Upgrade

We’re excited to announce that the Garmin Forums will soon be moving to a new platform that should greatly improve our forum experience for everyone. We will update everyone as more information becomes available.
See more
See less

D-Fly and Edge 520 Won't Connect After DI2 Firmware Update

Collapse
X
  • Time
  • Show
Clear All
new posts

  • #16
    D-Fly and Edge 520 Won't Connect After DI2 Firmware Update

    Alan, thanks for the reply.

    1. I do NOT have Connect IQ apps installed.
    2. I think I can figure out how to do a reset - do you recommend copying the settings.fit file before reset and copying it back after reset, or just manually resetting my settings?
    3. How do I reach Garmin support?

    Thanks.

    Comment


    • #17
      D-Fly and Edge 520 Won't Connect After DI2 Firmware Update

      Short version: problem solved.

      Long version:
      1. Spoke to Garmin and Shimano tech support. Both of them were convinced it is the other's problem and offered no help.
      2. Took bike to LBS and hooked it up to the wired version of DI2 updater (PCE1?). We found that the Dfly firmware needed to be updated, which is apparently not possible through the wireless version of eTube. DI2 updated continued to report that there was a communication problem with the wireless device - we finally gave up and I left the LBS.
      3. Went home and thought I'd give it one more try. eTube wireless connected right away to DI2, and I added the DI2 sensor to Garmin. And when I rode my bike today, the DI2 sensor was recognized by Garmin.

      Alan, thanks for your help.

      Comment


      • #18
        Hi Michael,

        I am having the exact same issue except I am using an EDGE 1000. It seems you have got a resolution though, but I am not clear from your post what it was that resolved the issue for you? I have tried everything you tried and no joy as yet. I assume it has now stayed working for you and the DI2 sensor is found every time and it displays the correct gearing and battery level?

        Thanks in advance


        Stevie

        Comment


        • #19
          D-Fly and Edge 520 Won't Connect After DI2 Firmware Update

          Hi Stevie. Couple of recommendations for you. If some of these are obvious, I apologize in advance.

          1. You have to "wake" the DI2 system before turning on the Garmin. I do this by leaving the chain on the small ring (when I end my ride) and pressing the shifter to move it to the small ring to "wake it". Basically, you just need to shift gears a few times to do the "wake up".
          2. I believe my real problem is that I had applied firmware updates to the DI2 system (which worked), but unless you are using the wired (PCE1?) eTube update method, you can't update the Dfly wirelessly. There was a firmware update outstanding for the DFly and we applied that using the wired connection. We then ran Check for Errors on the Dfly and were told there were errors, but it also told us to try Check Error again away from other possibly interfering electronics. Right, not sure where you can go for that.
          3. I then - at my home, not at the LBS - connected to DI2 from my smartphone using eTube. I didn't change anything so I can't say this was a part of the solution.

          Comment


          • #20
            Thanks for the response Michael. I am glad it is still working for you. So I initially had problems connecting with the e-tube app but eventually it worked and I update all components to the latest firmware. My D-fly unit. (the EW-WU101) is now sitting at firmware version 4.1.1

            If you have time, could you connect with your e-tube app to your unit and let me know the firmware version number is? Hopefully I am at least one version behind and thus that could be my problem. I am assuming that we have the same hardware model of d-fly as I know there are two..but the ew-wu111 is an internal type and not the strap on to the frame model and you mention early in your thread the unit was on the back of the frame.

            thanks in advance.

            Comment


            • #21
              4.1.1 is the latest build for the EW-WU101

              http://e-tubeproject.shimano.com/fir...model=EW-WU101
              - Alan

              Comment


              • #22
                D-Fly and Edge 520 Won't Connect After DI2 Firmware Update

                Hi Stevie. I am using:

                Master Unit / BT-DN110 / 4.2.5
                Junction A / SM-EW90-A / 3.0.4
                Wireless Unit / EW-WU101 / 4.1.1

                I left out the shifting systems - not thinking those are relevant.

                One other thought... before you exit the eTube app, do you Disconnect BLE? I remember being told by Shimano that the DI2 system could only be connected to one thing at a time. I'm not sure if Disconnecting BLE matters - it's just part of what I did.

                Hope this helps - let me know.

                Comment


                • #23
                  Thanks Michael. Some progress I think.

                  Early hours of this morning I followed your suggestion of changing the FD a few times to wake up the Di2 before I switched on the Garmin...and it connect straight away! I checked the data screens and was also showing the correct gearing in graphic display...so I was delighted. I tried again this morning, same process and yes it connected again, with correct gearing showing. I have not taken the bike for a spin yet so I can't say whether this is resolved permanently. For troubleshooting purposes though I will list what I have completed that is extra to what you carried out.

                  1. Fully updated all software via the e-tube app (this seems to have updated the EW-WU101 the the latest software)
                  2. Upgraded my Garmin Edge 1000 to the latest software (11.20) BEFORE trying to connect to the new Di2-fly (EW-WU101). This was a mistake as I never confirmed it was not working on the previous version of gamin SW (11.10)
                  3. After hours of frustration I decided to roll back my Garmin Edge 1000 software back to 11.10. To my dismay this wiped all my sensor data....so I tried to connect to the new di2-fly buy adding it as a new sensor...didnt work.
                  4. Re upgraded my Garmin to the most current software. I disconnect and reconnected the di2-fly battery feed lead and my Garmin discovered the di2-fly...but I had been here before and yes there was no correct gearing info displaying. Powered off the Garmin and sulked for an hour or so.
                  5. After discovering your thread and reading your advice about walking the di2 by shifting the big cog a few times before switching on the Garmin.......well I tried that one last time....and that was the early hours of this morning when it worked properly for the first time! Fingers crossed it stays this way.

                  Thanks for all your help so far Michael.......and of course Alan...who is undoubtedly a master troubleshooter as he has guided us both down the correct path !!

                  If you hear from me again on this post it will mean the success was only temporary....but as I said...fingers crossed.

                  Comment


                  • #24
                    This has been a very helpful thread as far as steps to try but unfortunately none of them have worked for me so far so I thought I'd add more info about my situation.

                    All had been working fine on my bike with the following components:
                    RD-6870-SS
                    FD-6870
                    ST-6870-L/R
                    BT-DN110
                    SM-EW90-A junction
                    EW-WU111 wireless unit

                    The bike did not originally come with the wireless unit but I added it about 3 months ago (1 month after purchase) and it's worked fine for those three months except I was never able to get my phone to connect to it (Android S8+) although the Garmin Edge 510 always connected fine. I wasn't too worried about that and just assumed it was some incompatibility with the latest Android phone/OS. Last night I got antsy though and wanted to figure out why the phone wouldn't connect, plus it was time to charge my battery anyway.

                    connected up my SM-BCR2 to the computer and SM-EW90-A junction and let the system charge to 100%. Once at 100% I opened e-Tube on my PC and hit the Update Firmware button. It updated fine and said something along the lines of only being able to update the EW-WU111 via the phone app. Seeing that all the other components updated successfully I disconnected the SM-BCR2 from the bike and proceeded to do as instructed - connect to via the phone app. This time, for the first time ever, my phone connected successfully and I proceeded to upgrade the firmware on the EW-WU111 via the phone e-Tube app. However, halfway through the upgrade it failed and didn't say anything more than it had an error during upgrade.

                    Now I can't get anything to recognize that my EW-WU111 is even present. The Garmin won't connect to it and the SM-BCR2 won't identify it. It's as if the failed firmware upgrade has rendered it useless :-(

                    Is my best/only option at this point to take it to the shop or otherwise find someone with the SM-PCE1 to troubleshoot the wireless unit on it's own separate from the rest of the system since the SM-BCR2 won't allow me to do that? Any help is much appreciated!

                    Comment


                    • #25
                      Not sure where the EW-WU111 is positioned in terms of your wiring set-up, but try disconnecting it for a few minutes form the power supplied by the battery and then reconnect it. This might allow it to reset and restart.
                      - Alan

                      Comment


                      • #26
                        Thanks for the quick reply Alan. I was actually going to write about that and got sidetracked and forgot. The EW-WU111 is located by my handlebar just about 3 inches from my Garmin. I've disconnected it (which, as I understand it, is similar to disconnecting the battery) for 30+ seconds and then connected it back up. I've also turned off my Garmin, then activated the Di2 by shifting both front and rear derailluers a few times and then turning on my Garmin but it still wouldn't connect. I also tried disabling the Di2 connection on my Garmin and then enabling it again but it still wouldn't connect whether I search for it or not via the Garmin. Again though, it's not just the Garmin that doesn't see it but also the e-Tube software on my PC doesn't recognize it anymore...

                        Comment


                        • #27
                          Try disconnecting the cable that runs from the control junction to the battery so that the control box resets.
                          - Alan

                          Comment


                          • #28
                            Well, that was a process. I figured I'd report back here about what I tried and what finally worked. Thanks to those that gave suggestions. aweatherall, I had previously tried disconnecting the cable from the junction box with no luck. So here's what I tried:
                            1. Rented an SM-PCE1 froma gentleman on eBay for ?10 for a 4 day rental
                            2. Plugged the SM-PCE1 via a single connection to the EW-WU111. It gave a message saying that there was a problem with the firmware and it couldn't update it so I should try via the E-Tube wireless app. Note that all I did was plug it in and connect it, nothing else here.
                            3. Put the EW-WU111 back into the bike and tried as it suggested with my phone (Android S8+) and this time the junction box was able to go into bluetooth mode successfully and the app connected up. The app then registered that everything was fine with the system and everything had the latest firmware (we're making progress!). Note that the Android app does not have the error check feature that the iPad app has (read more about that below).
                            4. I disconnected the app and tried connecting my Garmin - success!!
                            5. Then I had a feeling I should try connecting up my SM-BCR2 again since that's all I would have after I give back the SM-PCE1 that I had rented. Unfortunately, when I connected that up and ran the connection it got stuck doing the Connection Check and gave the same message that the SM-PCE1 had given in step 2 above - something about an issue found with the firmware on the EW-WU111 and told me to update that firmware via the mobile app (which I had already done in step 3, presumably).
                            6. Going on the instruction in #5 above I disconnected from the PC and connected my e-Tube mobile app up again. However, it said the same thing as in #3 above - everything looked fine from the e-Tube app on Android so I disconnected it again.
                            7. Then I decided to connect the SM-PCE1 up to the entire bike system (in #1 I had just connected it to the EW-WU111 alone) to see if it would detect anything else. It did not and I got the exact same behavior that I had in step #5 with the SM-BCR2 - telling me there was a problem with the EW-WU111 firmware and that I needed to update it with the mobile app. (Grr).
                            8. After a couple more times connecting the EW-WU111 directly to the SM-PCE1, putting it back on the bike, connecting the Android app, trying the SM-BCR2 again, etc., etc., I finally found a screenshot of the iPad app online somewhere and noticed that there is one extra function that the iPad version of the e-Tube app has which the Android version does not have. This is the key piece here! I grabbed my work iPad which I rarely use for anything except demos for work and downloaded the app. Connected up to the Di2 system via the app and it immediately started downloading a firmware update for the EW-WU111 (which none of the other methods of connecting had done). It finished the update and I checked the firmware number - it was still the same as it was before (4.3.4).
                            9. Thinking that I'd made progress because it clearly did something, I disconnected the iPad app and connected back using the SM-BCR2. Unfortunately I got the same thing as in #5 above again. (Grrr)
                            10. I disconnected the SM-BCR2 and reconnected the iPad app but this time went through the Error Check for the EW-WU111. It seemed to run just fine and reported back that all was well. Hmm.
                            11. I disconnected the iPad app and connected the EW-WU111 back up to the SM-PCE1 directly (standalone) again just to see if anything was different now that the iPad app could see it. Sure enough, it could see it now and everything seemed to work while connected directly to it.
                            12. I disconnected it from the SM-PCE1 and put it back on the bike. Then connected the SM-BCR2 and all connected up fine this time. I double-checked that the app connects to it (both the Android one and the iPad one) and it does. So all seems well now.
                            I still can't tell you exactly which step fixed it all for me but it was some combination of step #8, fact that the iPad app clearly has different logic than the Android one and is better at detecting firmware issues, and step #2 merely plugging the EW-WU111 into the SM-PCE1 without doing anything else (it was after that step specifically where the Garmin started connecting successfully, even though there were still lingering problems with the firmware).

                            So, moral of the story: Don't use the Android version of the Shimano e-Tube app unless you want to nearly brick your EW-WU111 unit. :-) Use the iPad version of the app.

                            I hope this helps someone, if nothing else, I can refer back to it here now, haha! And I'm much more well-versed on Di2.

                            Comment

                            Working...
                            X