Announcement

Collapse
No announcement yet.

Course navigation in Firmware 2.60

Collapse
X
  • Time
  • Show
Clear All
new posts

  • #16
    They've made a right mess of the course navigation feature. I just went for a quick ride on my normal 12 mile route. Prior to that I did a factory reset and reloaded the course from a previously saved file from an actual ride. Nightmare ! The thing bleeped constantly every few seconds and went to the navigation screen. I persevered with it and it seems that the problem is this : the unit constantly flashes up that you are not following the course (even though you are). The warning is to tell you how far you're off course and which direction to ride to get back on the course. After a few seconds it thinks you're back on course and shuts up, until it loses you again. You'd expect that the final plot of your ride would show you're constantly off course but it doesn't. It's perfect as normal.
    During the ride I tried turning off Glonass and just using GPS. I also changed the data from 1s sampling to smart intervals. No difference.
    Don't Garmin test their firmware on real live units ? ie ones that people actually go out and ride with. Or are we their guinea pigs ?

    Comment


    • #17
      I went for another ride yesterday following a course created at bikeroutetoaster. On bends the unit is constantly giving me course direction change alerts. Hopeless.

      Comment


      • #18
        I was unpleasantly surprised to discover this behavior when following a course on Saturday with my 510. Every bend in the road would throw annoying alerts at me and make the course track disappear and reappear. The course was about 50 miles.

        Even worse (or maybe better?), about 16 miles into the ride my Edge rebooted itself. I stopped and tried to load the course again, but it remained stuck on the course loading screen for a very long time, so I turned the unit off and on again. This time the unit came up and after I started recording the ride (without trying to load the course), I swiped over a couple of screens and actually found the course was loaded and I was following it in the "old" mode, where I just saw the gps track and didn't get any notifications. This worked well for the rest of my ride.

        And in case the Garmin folks want to view the ride data, here are the two saved sessions:

        http://connect.garmin.com/activity/331505944

        http://connect.garmin.com/activity/331673133

        Scott
        Last edited by ZENLINUX; 06-24-2013, 09:50 PM.

        Comment


        • #19
          What file format are you sending to the 510? I did a short course I loaded from bikeroutetoaster.com today and it worked. Counted down to the next point, gave me the message turn left/right, then counted down to the next point. The screen refresh would still hang at course points and the distance measured it still low, but I was able to follow the course.

          I sent the file to the 510 in .tcx format. I remember sending it in .gpx format once and got constant turn left/right messages.

          Comment


          • #20
            Ouch!! Tried a course created at ridewithgps.com today and sent it to the device using .tcx file format. Non-stop "Head South, Head Southeast"....... Beeps every 30 seconds or less. Finally had to stop the course. Trying another course created on bikeroutetoaster.com on the way to work in a couple hours in the car. Maybe I was dreaming or just lucky yesterday.

            Comment


            • #21
              Another "Me, too". This update is horrible! I can't go 5 seconds on MTB before it beeps at me. I was hoping to use virtual partner to race against my previous best time on some twisty MTB route but the constant "Head South", "Head West" messages made it impossible. Its not easy to fumble through the screens to disable the course while hammering an uphill technical time trial but luckily I was able to stop the course without stopping the bike. I'd prefer to not go back to old revisions, but this is ridiculous.

              Comment


              • #22
                Originally posted by MTNC1 View Post
                Ouch!! Tried a course created at ridewithgps.com today and sent it to the device using .tcx file format. Non-stop "Head South, Head Southeast"....... Beeps every 30 seconds or less. Finally had to stop the course. Trying another course created on bikeroutetoaster.com on the way to work in a couple hours in the car. Maybe I was dreaming or just lucky yesterday.
                Yeah, that didn't work either. It's a joke trying to follow a course. Does Garmin even put these updates on a unit and try it out before releasing it?

                Comment


                • #23
                  Glad to see I'm not the only one having an issue with it.

                  I've learned that it's a really big problem when using courses which have been created from previous rides, or as some of the above posters have said, created from other sites. When using one of these courses, it'll beep every 10 seconds or whatever.

                  It doesn't seem as bad when using courses created in Garmin Connect in my browser. It doesn't seem to bring up that off-course window. However, I would still prefer to be able to turn off the navigation since I'd like to be able to have JUST the map and my 1 or 2 data points showing.

                  To be honest when I'm riding a predefined course, I'm less concerned with if I'm going N,E,S,W than if I'm actually on the course. Especially with the 510 with no actual maps, all I have to go on is the little squiggly map. I like to blow it up to a decent zoom level and be able to judge where a turn is coming, it doesn't mean much to me if it's east or west since there's no roads or anything else to get my bearings with.

                  Garmin, please:

                  • Add the ability to disable the "enhanced" navigation
                  • Fix the "enhanced" navigation so it doesn't think you're off course every 10 seconds when using a course created from a saved ride / other site


                  It would be much appreciated.

                  Comment


                  • #24
                    Same issue. It seems to me it is not to do with the thing thinking you're off course, but it having no way of distinguishing a road that curves from an actual turn onto a new road -- so it constantly warns you that you need to change direction.

                    I see no way this works unless you are riding 100% entirely straight roads.

                    In any case the device is now ruining my rides -- the beeping literally every 5 seconds drives me crazy, and the map screen is never visible so I have no idea where I should be going. Completely useless now. How do I return it for a refund?

                    Comment


                    • #25
                      Based on some correspondence I have had with Garmin they are aware of this issue where the Edge warns of each track point and gives guidance to it. They are working on a fix for it as this is not the intended behavior, but I don't know when it will be available.
                      - Alan

                      Comment


                      • #26
                        I'm giving up on Garmin. Can you send products back, or do I have to just chuck it in the bin?

                        I had ongoing emails with their 'support' team and tried to help them as much as possible, but they simply lie, then ignore.

                        Comment


                        • #27
                          Originally posted by THESTONE77 View Post
                          I'm giving up on Garmin. Can you send products back, or do I have to just chuck it in the bin?

                          I had ongoing emails with their 'support' team and tried to help them as much as possible, but they simply lie, then ignore.
                          A bit over dramatic. Generally the unit works pretty well. I'm sure they will sort out the course issues.

                          Comment


                          • #28
                            Originally posted by 3DKIWI View Post
                            A bit over dramatic. Generally the unit works pretty well. I'm sure they will sort out the course issues.
                            I'm more than fed up now. Didn't realise this forum existed before.

                            I emailed support about tcx files causing the unit to crash (requiring a master reset each time). Sent as much information as I could, helped as much as possible.
                            Eventually they came back saying that my tcx files were corrupt, even those from Garmin Connect.

                            I can now see that they knew this was a bug all along, so why did they lie and waste my time? They've ignored everything for last month.

                            This latest, massive bug in the course navigation make the unit unusable. I really just want to send it back. Do they ever test these products or updates before sending them out? I doubt it.

                            Maybe I've got a defective one ..... but I reckon they're all this bad.

                            (I've had many Garmin products over the years. Edge 205, 605, 500 and now 510, plus Forerunner 410. The 500 was good, eventually)

                            Comment


                            • #29
                              Maybe I've got a defective one ..... but I reckon they're all this bad.
                              It's a firmware issue. We're all in the same boat.

                              If you're not happy you should request a refund from wherever you purchased your Edge from. Me, I'll wait until the firmware is updated (yet again).

                              I agree, it doesn't seem they do any testing.

                              Comment


                              • #30
                                The way I see it, everyone uses this device to achieve different results (simple bike computer, navigational aid, uploading and reviewing rides on connect, strava, etc).

                                Each person will have there own opinion on this device based on there expectations and what they have been using the device for, I agree its not bug free and far from it, but I reckon the majority of people out there who buy the device, turn it on, press start, do their ride, save and upload, they are the ones who probably wont ever come across any bugs or have any issues.

                                Unfortunately for those who want the other features (like me), its a waiting game, as you said the Edge 500 was good 'eventually', give this some time and it will be as good if not better (heres hoping). I am running FM2.5 I personally won't upgrade my device for probably another 8 - 12 months when most (if not all) of the bugs have been worked out.

                                You have a new device with some great features, obviously some are hindered at the moment but this will change in due course (hopefully). Not aiming this at anyone on the forum, but it pays to wait before proceeding with an upgrade (reading other reviews), especially when others have said there device has become unuseable. But I dont know your circumstances as to when you ugpraded, i.e. yesterday, or when the update was released.

                                I would love turn by turn directions, but I am quite happy to load a course and keep checking the screen every now and then to see how I'm going or where abouts I am on a course, however I dont ride off roads and the roads I'm on I'm somewhat familiar with.

                                I dont side with Garmin in anyway, I too have lost my patience, but why keep fighting a battle that one is unlikely to win.

                                Hopefully the next upgrade will come around soon that will fix all units and make the course feature useful, otherwise you can roll back your firmware using the FirmwarePatcher method as listed by JAYMEFERREYRA and go back to FM2.5.

                                Sam

                                Comment

                                Working...
                                X