Announcement

Collapse
No announcement yet.

Firmware update

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Firmware update

    Hello Community. I'm trying to update my Edge 510 (2.9 firmware) to the latest via Mac Computer. I have tried to use ...

    1) Webupdater ... and the application did not recognize my Edge 510 device.
    2) Garmin Express ... and the application did not recognize my Edge 510 device.
    3) I did a factory reset on Edge 510 and did the above #1-2 again ... and still didn't recognize my Edge 510.
    4) "My edge is not recognized by my computer" article from Garmin Troubshoot (https://support.garmin.com/faqSearch...TL57tN38aI6m29) and it didn't work.

    Can anyone of you help me so that I can update?

    Thank you!
    Sincerely,
    David

  • #2
    You can do a manual install. This website contains the files for many Garmin devices. Download the file and rename it to gupdate.gcd and place it in the Garmin folder on the 510. When you disconnect the Edge from the PC it should start the install.

    http://gawisp.com/perry/edge/Edge510_610.gcd
    - Alan

    Comment


    • #3
      Hi Alan, thank you for the info. But computer (mac) is not detecting my Garmin Edge on the computer so that I can manually install the file in "Garmin Folder." I'm so frustrated.

      Is it my computer issue? I just got the Varia Radar device and I'm trying to registered even this new product through the Garmin Express and it won't detect it.

      Comment


      • #4
        This sounds like an issue with the Mac or the cable you are using if it will not recognize either device. What build are you running on the Mac? You can try forcing the 510 in to mass storage by
        Force to Mass Storage -
        Turn unit off. Hold the lap/reset button while plugging the unit into the USB. Continue holding the lap/reset for 30 seconds and the unit should go to mass storage.

        - Alan

        Comment


        • #5
          Thanks again for your suggestion. I have tried that option too (I found online). The Edge 510 goes to the icon that shows it wants to connect to computer. But, the mass storage is not detected by Mac. I have tried several different usb cords that are new. And no luck. I also tried on a PC and MAC and it's not picking up for some reason. I will be contacting Garmin and see what they say. I am running Mac OS 10.12.6

          Comment


          • #6
            found the issue! Thanks Alan. I needed to use Garmin usb cable. I thought i was using the Garmin usb cable but I was not. As soon as I changed to Garmin usb it recognized the device and I am able update. Same with Varia, I used the Garmin usb cable that came with it to plug into my Mac. and it worked. Sorry for the trouble.

            Comment


            • #7
              No problem. Some USB cables only have the power pins connected and not the data pins as well.
              - Alan

              Comment

              Working...
              X