Announcement

Collapse
No announcement yet.

Garmin Edge 500: activities not appearing, lost or deleted

Collapse
X
  • Time
  • Show
Clear All
new posts

  • #16
    Originally posted by DAVIDEFREY View Post
    this may be of interest to developers:

    Recordings 1 2 3 were not lost this time. It looked like it on the device. But once downloaded there was 1 single file with a name that should have been associated with recording #1 and containing all the data of the four (I think, but 3 of them for sure) recordings.
    I am positive that I reset the timer after each recording. During the last ride home, the timer was correctly indicating 1h11 at the end, whereas the recording that was saved spans all the 5 hours in my afternoon.

    hope this helps

    Davide
    I went into the file after converting it to TCX and the laps were saved with the correct times and distances. so it was an easy task to split the huge workout into it's constituent parts. I also tried to go back to my old activities to see if I could recover the one I had lost last week, but with no luck.

    Comment


    • #17
      My unit has been hard locking upon pressing the lap button for the last 10 or so training sessions. Today is the straw the broke the camels back!!!

      I did an easy 16 mile ride over to todays race site. Reset the unit prior to race start. Upon race completion I hit the lap button to separate my race from my cool down. Upon hitting the lap button the unit HARD LOCKED!!!!

      I arrived home in the hopes of being able to salvage the data from the race. Well, IT IS GONE! The only records on the device are from my ride to the race site.

      Are there any archive files or anything on the device that I can salvage that data from?

      Any help would be greatly appreciated!

      That aside I am appalled at how lousy this device is turning out to be. I have great respect for Garmin products and their supper has been great, however, it seems as though this particular device has way to many issues to serve as a reliable training tool!

      Comment


      • #18
        Originally posted by MCAMPBELL371 View Post
        I've followed the second procedure you outline (as is also outlined by Garmin in the user's manual) and still lost data.

        There is clearly a software glitch that needs to be addressed by Garmin. I don't care how many people haven't lost files yet. I'm sure they will eventually.
        A lot of people have the same problem... Myself, and I know other 2 friends that have the Edge 500 with the same problem: often data are lost!!! Following the correct procedure...
        I suppose that Garmin have to ad a security step in the workflow of the course memorization that must include the "auto save" every 1 minute, creating a integer and fixed backup file in a separate folder. So If you can't read automatically the .fit file, you can read the backup file . That have to be fixed, not corrupted . New firmware please!!!
        -----------------------
        Forerunner 305
        Edge 500
        ------------------------

        Comment


        • #19
          Add another one to the list who lost a data file 'magically' on the Edge 500! I always follow the correct procedure and did the same after today's 3+ hour ride. I got home today and, while the file appears to be there, it is a 'zero kb' file. I'm so pissed!

          Come on Garmin-Fix your stupid firmware already!!!!

          Comment


          • #20
            Maybe a fix

            I too have lost data on my 3 week old Garmin Edge 500 ver 2.30. I have an issue where if I press the stop button the display says timer stopped but the timer keeps ticking away. I don't hit the reset button because the system seems to lock or data is lost. However when connecting the device to the computer I can in fact download data provided I did not power the device down. Strangley the data downloaded shows that the ride completed exactly when I hit the stop button.

            This was all driving me crazy so I decided to fiddle and here is what happened........ I copied all folders from the device to my local drive. I formatted the device. I disconnected the device from the computer and then powered it up. Timer stop and start now works as does reset button. Power off and on results in data being held. I copied some of my backed up .fit files back on to the device. My history and data settings started to reappear on the device. My screen 1,2,3 layout was different though and I did not find the fit file responsible for this. I went into the system and made the changes to the layout that I previously had. Power down and then up again and so far looks okay. However there are issues still. They are: Garmin triangle associated with the device does not appear next to the device name under my computer - despite the icon being in the correct place and Autorun.inf pointing to the right place. This not really an issue for me but I wonder why. Also on connection of the device windows says there "could" be a problem with the device and recommends a scan. I click scan and fix but it never finds any errors.

            My only other thoughts are should one hit eject or the safley remove device in windows before physically disconnecting the device from the computer. Failure to do so could corrupt the disc or data or both. This could account for everybody eventually having troubles.

            I will try thisfor a few days and let you know how I go. I would not recommend trying it until you hear back from me. If it fails I will be placing the device under the wheel of my car to ultimatley solve the problem.

            Comment


            • #21
              Add me to the list of VERY MAD people losing data with the Edge 500.
              I owned an Edge 305 before this,... that unit was good.

              There should be nothing that you can do by pressing or not pressing buttons, using or not using certain options or waving garlic over it that should cause it to lose data. That is 100% UNACCEPTABLE. The fact this unit made it through testing is a giant clusterf...

              My usage is really simple: Auto-Stop (when stopped), Auto-Lap at 5K, start, stop, sometimes I press reset right away, sometimes I do it later when I get home (by which time the unit has either been self-powered down or manually powered down). I might accidentally hit Lap before hitting Stop because I haven't programmed my brain & hands to know the buttons yet and some GENIUS decided to put the buttons on the side and the labels vertically.

              Seriously "NOT LOSING DATA" should be the number friggin' one priority on a device like this.

              VERY VERY VERY VERY VERY VERY MAD.

              Comment


              • #22
                Ride yesterday:
                1. Hit start
                2. Ride 195 miles (Mt Tam Double)
                3. Severely depleted, didn't think to hit stop, or anything other than recovering
                4. 2 hours later, notice Edge is on, so I shut it off
                5. drive home, check device, no data


                Okay, so I clearly screwed up. But nevertheless, the process I followed was too simple to cost me 12+ hours of ride data without warning.

                User interface design on a device like this needs to be robust: the user is often in an impaired state at the end of an activity. Crashes, exhaustion, and other sources of destraction are common, yet losing data is a serious matter. I for one was extremely interested in how checking to see where I'd lost time in event relative to the leaders: was it on the climbs? On the flats? The amount of time I spent in aid stations? I'll never know.
                Last edited by DJCONNEL; 08-08-2010, 08:22 AM.

                Comment


                • #23
                  how I'd fix it

                  Here's how I'd fix this problem.....

                  If the unit is considering deleting data, instead put it in a trash folder in the Activities directory. If files in the Trash folder reach a week old, delete them after checking with the user: "clean up trash folder?"

                  There's a lot of space in that NVM: no reason to get draconian.

                  Comment


                  • #24
                    Originally posted by DJCONNEL View Post
                    Okay, so I clearly screwed up. But nevertheless, the process I followed was too simple to cost me 12+ hours of ride data without warning.
                    That really sucks, sorry for your data loss. Congrats on the double century.

                    What firmware version are you running? Did you look around the directory structure on the device to see if there were any files there? Perhaps you have a corrupt/partial FIT file that can be recovered. I have written my own FIT parser that might help.

                    [EDIT - I see in your follow-up that you presumably did look around the directories.]

                    Your case seems particularly worrying as I don't see that you did anything "wrong" at all. You just had a couple of hours of inactivity at the end of an activity. It sounds like the device didn't power down, and that when you noticed this you did the usual things to end the activity. How much inactivity is one allowed before the device decides to toss the data?

                    As a happy, non-data-losing, long-time Edge 305 user, I've waited about a year before buying the Edge 500 because of problems like this. Now I've finally ordered one as I thought the firmware was getting there, but after this I might just cancel it and go back to wait mode.
                    Last edited by UKBLOKE; 08-08-2010, 11:21 PM.

                    Comment


                    • #25
                      Originally posted by DJCONNEL View Post
                      Here's how I'd fix this problem.....

                      If the unit is considering deleting data, instead put it in a trash folder in the Activities directory. If files in the Trash folder reach a week old, delete them after checking with the user: "clean up trash folder?"

                      There's a lot of space in that NVM: no reason to get draconian.
                      I agree with your solution. I lost data today for the first time. It was probably user error, but can't that data be saved somewhere instead of being eliminated?

                      Comment


                      • #26
                        Is everyone running the latest firmware (2.4)?

                        Its inexcusable that the Edge 500 loses data but I'm just curious if this phenomenon has been fixed or at least improved with the latest firmware.
                        Ron

                        Comment


                        • #27
                          Yes -- I'm running 2.4; upgraded last week.

                          I shut if off without "stop" and "reset", so I wasn't RTFM-compliant. So I take the blame, sure, but that's a harsh sentence.

                          Comment


                          • #28
                            DJCONNEL,

                            From your follow up post on 8/8, it sounds like you may have looked for the actual file in the Activities folder. Was there any activity in the folder, that was recorded on that date?

                            If there is, have you tried a manual upload, by going to Upload > Manual Upload > Browse, and selecting the FIT file from the Activities folder on the Edge?

                            If you were able to find the file, and it will not upload, please attach it to your reply.

                            -Damon-

                            Comment


                            • #29
                              Add me to list

                              I have been trying to keep a log of my miles this year due to our company raising money for charity. So, if I miss miles, the charity loses as well! If I don't remember or log in my book right after ride, they are gone as I ride every day and no way can I recall without "fudging", I want to keep it honest for my sponsors. I got the Garmin as my husband has the older model and he told me I would love it. I was shocked to find out when I went to do a log entry for the early part of year in book that many of my rides were missing. I do pretty much what most of you are and don't mess with buttons mid ride so its pretty disappointing and to me, the part of having this unit should not result in me having to come home and keep track ASAP, that is what I paid for.

                              Now my unit is acting up in other ways, calories holding during ride at same point, heart rate not showing up and erratic, cadene not working, and I have a crazy ride with 8000 miles on my screen that comes up when first viewing history. And saying I did it in a couple of hours?!!! Hoping the company will see all of this and try and do the right thing. The company did not stand by my husband when he had a problem with his so I won't hold breath!

                              Comment


                              • #30
                                Hi People,

                                I experienced loss of datas like a lot of user... but I found a procedure that allows to retreive datas or cases where they have disappeared from the history!

                                follows this thread:

                                https://forums.garmin.com/showthread.php?t=11141

                                Comment

                                Working...
                                X