Announcement

Collapse
No announcement yet.

Garmin Express Fails to Install

Collapse
This topic is closed.
X
X
  • Time
  • Show
Clear All
new posts

  • Garmin Express Fails to Install

    I upgraded to the modern Garmin Connect and need Express to upload workouts from my Forerunner 220. Halfway through the initializing phase of the installation it stops and says "Failed.Try again?" it never works.

    PC running Vista.
    Help

  • #2
    When I opened Garmin Express in Vista I get a notification that it needs to close to install an update. It does that and the update 3.1.7.0 begins to install. The installation completes partially and than a "Failed to Install" message appears with the option to retry. Retrying...and retrying from Administrator account produces the same results. Earlier version of Express Updater worked fine. Suggestions?

    Comment


    • #3
      Garmin Express essentially runs on top of Microsoft's .NET Framework. When installing, Garmin Express checks the status of Microsoft's .NET Framework and initiates an update if needed. If the .NET Framework update fails, the "Failed Try Again" message will appear. This usually means there was an issue with .NET Framework. Use the .NET Framework Repair Tool in the FAQ: What should I do if I encounter a Microsoft .NET Framework error while installing or using a Garmin application?

      Curt
      sigpic

      Comment


      • #4
        Originally posted by EXPRESSCUSTOMERCARE View Post
        Garmin Express essentially runs on top of Microsoft's .NET Framework. When installing, Garmin Express checks the status of Microsoft's .NET Framework and initiates an update if needed. If the .NET Framework update fails, the "Failed Try Again" message will appear. This usually means there was an issue with .NET Framework. Use the .NET Framework Repair Tool in the FAQ: What should I do if I encounter a Microsoft .NET Framework error while installing or using a Garmin application?

        Curt
        This is without a doubt, the lamest customer support response I've seen from a vendor in the past decade. Pointing users to the OS vendor rather than dealing with this sort of thing within a front-end application is weak. Support? Hardly.

        On top of that lameness, the .NET Framework Repair Tool was "unable to resolve the installation issue on my computer." Pathetic. This customer is disgusted with this...

        #fail.

        Comment


        • #5
          There isn't a problem with installing Garmin Express on Vista machines in general. Thousands of Vista users have successfully installed the application and are using it with no problem. In your particular case, there appears to be an issue. The most likely cause of that issue up until this latest release was the .NET Framework. The latest Garmin Express client 3.2.4 requires that older Vista and XP SP3 machines have the latest version of Microsoft Windows Installer 4.5 installed. If your machine is not fully up to date with the latest Microsoft software then you may start to have trouble installing newer application created by many different vendors. You can install Windows Installer 4.5 from: http://www.microsoft.com/en-us/downl...s.aspx?id=8483

          Curt
          sigpic

          Comment


          • #6
            "Thousands of Vista users have successfully installed the application" I have vista and am having the exact same problem.

            Comment


            • #7
              What 'exact same problem'? What have you tried from the suggestions above?
              Currently own Drive 50LMT-D, Nuvi 2508LMT-D, Nuvi 1490LMT, Nuvi 1310, Montana 650T, Etrex 20, and use Basecamp, OSM mapping
              Previously owned Etrex Legend H, Mio Navman and used Mapsource
              (please note that I am not employed by Garmin, but am a long term user of Garmin software and hardware)

              Comment


              • #8
                Originally posted by SUSSAMB View Post
                What 'exact same problem'? What have you tried from the suggestions above?
                Well I'm running XP SP3 and have the exact same problem. I connect my garmin 2595, Express launches then says update is required. The Express installer says version 3.2.7.0 initializing, then installing, then failed! retry again?

                Something is wrong with this installer. at the very least it should say WHY it failed.

                Comment


                • #9
                  So as posted above have you tried the .net repair tool ... link is also in one of the posts above ... and also ensured your Windows Installer is up to date ... link also posted above?
                  Currently own Drive 50LMT-D, Nuvi 2508LMT-D, Nuvi 1490LMT, Nuvi 1310, Montana 650T, Etrex 20, and use Basecamp, OSM mapping
                  Previously owned Etrex Legend H, Mio Navman and used Mapsource
                  (please note that I am not employed by Garmin, but am a long term user of Garmin software and hardware)

                  Comment


                  • #10
                    3.2.7.0 forced update screwed Express up

                    Originally posted by GFRIEDMAN99@YAHOO.COM View Post
                    Well I'm running XP SP3 and have the exact same problem. I connect my garmin 2595, Express launches then says update is required. The Express installer says version 3.2.7.0 initializing, then installing, then failed! retry again?

                    Something is wrong with this installer. at the very least it should say WHY it failed.
                    I agree completely. THe version 3.1.9.0 was working perfectly. Then the update to 3.2.7.0 and now it fails with no other information. The .net 4.0 is loaded with out errors and the ms installer works as designed. still receive "FAILED" after multiple attempts. Garmin support has screwed something up once again and puts the blame on everything else but the real problem their terrible software. Fix the screw up or at least give the user the option when to take an update. Needing to use the update maps option before a trip to have to deal with a failed update for Express is the worst.

                    >net repair tool no issues
                    >installer re-installed and re-registered
                    >uninstalled express attempted reload .. FAILED>> Try again!

                    Pissed off and really ready to stop buying any garmin products period.

                    Comment


                    • #11
                      I have exactly the same problem as Alwins...done my updated of workouts this morning and had the new update for garmin express installed which totally does not work....i.e. fails to install... and was just about to buy 910 ....now i will reconsider since i definitely do not want to change my computer to have it all work

                      Comment


                      • #12
                        If both of you are sure Windows installer is up to date and you have .net installed correctly try here http://windowsperformance.blogspot.c...of-garmin.html
                        Currently own Drive 50LMT-D, Nuvi 2508LMT-D, Nuvi 1490LMT, Nuvi 1310, Montana 650T, Etrex 20, and use Basecamp, OSM mapping
                        Previously owned Etrex Legend H, Mio Navman and used Mapsource
                        (please note that I am not employed by Garmin, but am a long term user of Garmin software and hardware)

                        Comment


                        • #13
                          Originally posted by GFRIEDMAN99@YAHOO.COM View Post
                          Well I'm running XP SP3 and have the exact same problem.
                          You do realize you are running a unsupported operating system?

                          Comment


                          • #14
                            Well that's true but AFAIK Express still works with it provided Windows Installer has been updated.

                            Edit: Although just realised even though others were talking about 3.2.4 he's talking about 3.2.7 which requires Vista and above according to the requirements on the web page but this earlier from Customer Support

                            Originally posted by EXPRESSCUSTOMERCARE View Post
                            Moving forward future versions of Garmin Express will not be compatible with Windows XP. Microsoft has ended support for this operating system and Garmin is moving away from this system as well. Garmin strives to be Microsoft compliant and in doing so will not be developing new products for the XP system. Currently XP systems can install the latest version of Express for now.
                            Mike
                            Last edited by SUSSAMB; 06-15-2014, 05:24 AM.
                            Currently own Drive 50LMT-D, Nuvi 2508LMT-D, Nuvi 1490LMT, Nuvi 1310, Montana 650T, Etrex 20, and use Basecamp, OSM mapping
                            Previously owned Etrex Legend H, Mio Navman and used Mapsource
                            (please note that I am not employed by Garmin, but am a long term user of Garmin software and hardware)

                            Comment


                            • #15
                              well it should not be done with a forced update.... i am not changing my computer nor the system to vista...which means that all the garmin products are kind of useless for me.... definitely in this case will not wast money on 910. let's see what polar offers

                              Comment

                              Working...
                              X