Announcement

Collapse
No announcement yet.

BMW Navigator VI - not recognised - DELL Win 10

Collapse
X
  • Time
  • Show
Clear All
new posts

  • BMW Navigator VI - not recognised - DELL Win 10

    HI All - hope somebody has the fix to this.
    I just bought the Garmin BMW Navigator VI but when I plug it to my DELL laptop (Win 10), nothing happens. I can only see the navigator switching on and that the battery is recharging.
    I went though different forums and it seems there is an issue with Win 10 but I could not found the solution.

    I need to connect it via Garmin Express to register it and make all required updates but, as I said above, it is not recognised.

    Any suggestions? Something I need to somehow update on the nav before it gets recognised?

    The Laptop is a DELL XPS running on Win 10.


    Thanks
    Christian



  • #2
    Hmmm ... this could be a number of things. Are you using a data rather than power cable? Ideally you should be using the one that came with your device.

    Next, if you're plugging into a USB3 socket try a USB2 if you have one.

    There is more detail in the Garmin FAQ here:

    https://support.garmin.com/en-US/?fa...urce=faqSearch

    Finally, Win!0 can have issues connecting to mtp mode devices, which yours is. Try changing it to mass storage mode:

    1. Start device by itself and go to Volume Screen.
    2. Press the upper right hand corner of screen for 10 seconds.
    3. The Developers Screen will pop up
    (may see Configuration and Settings, if so select it)
    4. Scroll down to MTP SETTINGS
    5. Change from AUTO DETECT to MASS STORAGE
    6. Shut down the device and connect to PC
    7. It should now connect in mass storage mode.

    As an alternative to step 1 and 2 above, you can bring up the "trip information" screen by tapping the speed icon, then press and hold the speedometer for about 10 seconds to access the developer screen. Now go from step 3.
    Currently own Drive 50LMT-D, Nuvi 2508LMT-D, Nuvi 1490LMT, Nuvi 1310, Montana 650T, Etrex 20, and use Basecamp, OSM mapping
    Previously owned Etrex Legend H, Mio Navman and used Mapsource
    (please note that I am not employed by Garmin, but am a long term user of Garmin software and hardware)

    Comment


    • #3
      I found the fix for the issue.


      Root cause
      In my case the issue was the compatibility of the Garmin device with the USB 3.0 ports of my laptop.
      I am not sure if the issue is with all USB 3.0 ports in any computer or only with some specific USB 3.0 controllers / drivers

      How I fixed it
      - I bought a USB 2.0 port hub. (https://www.trust.com/it/product/205...rt-usb-2-0-hub)
      - I connected the USB 2.0 port hub to the laptop
      - I connected the BMW Nav VI to the USB 2.0 port hub
      Like this:
      NAV VI ---> USB 2.0 port hub --> USB 3.0 Laptop USB port

      - Finally the laptop could recognise the navigator and I could work on it as normal with Garmin Express and make registration, updates, etc...


      It might good if somebody can make the Germin support via chat aware of this. When I had a chat with them they were saying that the issue was with the USB ports not providing enough power to the navigator to be able to recognise it!!!! Despite I was telling him that the navigator was even being charged and there was no lack of energy on the USB ports (as they also could be used as power supply)

      Anyway... this is how I fixed the problem

      Cheers and thanks for your answer.

      Comment


      • #4
        Same issue with my Navigator V and USB 3.0 port on my HP Spectre laptop running Win10. Workaround:
        - plug in device to USB 3.0 port on laptop
        - reboot laptop
        - device recognized

        Comment


        • #5
          Hi,

          just tried this workaround also but it does not work in my case... I need to keep using the USB 2.0 port hub.

          thanks

          Comment

          Working...
          X