Announcement

Collapse
No announcement yet.

Garmin Express will not open Garmin Connect to add new device.

Collapse
X
  • Time
  • Show
Clear All
new posts

  • Garmin Express will not open Garmin Connect to add new device.

    I am trying to add my Fenix 3 HR to GE in order to set up WiFi and in order to update the firmware. When I open GE the Fenix is recognised and connected. I then get the sync with connect screen. I already have a connect account yet every time I hit the sign in button I get a blank screen which does nothing! (I've tried the create account button but same thing happens). An older version of GE had my FR410 on it back in the day and that synced fine. Has anybody else had a similar issue as this is driving me mad!! Thanks.

  • #2
    Reinstall Garmin Connect.

    Comment


    • #3
      I’ve completely uninstalled and reinstalled about four times but it makes no difference?

      Comment


      • #4
        I have the same problem here. Got my new Garmin 645 Forerunner Music today, Garmin Express says Forerunner 645 Music connected, but when I try to sign in I have the same blank screen! I hope someone can help us!

        Comment


        • #5
          Originally posted by Teun View Post
          I have the same problem here. Got my new Garmin 645 Forerunner Music today, Garmin Express says Forerunner 645 Music connected, but when I try to sign in I have the same blank screen! I hope someone can help us!
          I’m hoping Garmin are helping. They’ve requested various info and logs etc which I sent them 48 hours ago.....fingers crossed I hear back!! I’m running a 27” 2011 iMac with latest OS.

          Comment


          • #6
            Same problem here! Tried to set up the WiFi for my Edge 1000 and all I can get is that white screen!! I've uninstalled and reinstalled several times, cleared cache, delete Garmin Express folder form library... Nothing works!!! The funny thing is that it used to!! Garmin, WE NEED A SOLUTION!!

            Comment


            • #7
              I remember I installed a new Java version on my Mac the day before I installed Garmin Express. I have no idea if that has anything to do with our problem? Did you do the same?

              Comment


              • #8
                Originally posted by Teun View Post
                I remember I installed a new Java version on my Mac the day before I installed Garmin Express. I have no idea if that has anything to do with our problem? Did you do the same?
                Not working. Java says I have the latest version, and I reinstalled it. Also tried to change the default web browser to Firefox or Chrome, no luck. We need to solve this!!

                Comment


                • #9
                  Well I’ve still not received a reply from Garmin after their initial couple of responses. I’m going to try installing GE and adding my Fenix onto a friend’s MacBook this evening. Will let you all know how I get on tomorrow.

                  Comment


                  • #10
                    I’m having the same exact problem, albeit I’m running an older mac(2008) with older os(elcapitan). I thought my machine had finally been outdated. I’ve tried all of the above to no avail. This happened after an update of ge, with a new device. I have two others and they worked flawlessly before.

                    Comment


                    • #11
                      Any luck jpoc71

                      Comment


                      • #12
                        Same exact problem here. Error message saying I need to reuthenticate with Garmin Connect, then a blank login screen with just a cancel button. Tried reinstalling Garmin Express, removing ANT stick, etc etc etc. No good. Clearly some sort of bug in the newest Garmin Express install (6.11.0.0). HUGELY frustrating. Hopefully Garmin is monitoring this forum (otherwise what's the point of it?).

                        Comment


                        • #13
                          Originally posted by Farthergriz View Post
                          Any luck jpoc71
                          Well I’ve managed to get it sorted at last. I’m pretty sure that the problem is a compatibility issue with El Capitan. I Installed the latest GE on a friend’s MacBook and managed to load everything no problem, thus determining that it wasn’t the watch that was the problem. I got home and updated my iMac to High Sierra (the newest that it can take) and hey presto GE worked perfectly.
                          This is what should come up when you hit the log in button.
                          Hope this helps!
                          B79C8AE3-9709-47AE-A9B3-09E3E384E031.png

                          Comment


                          • #14
                            Thanks for your info. I'm running El Capitan because my MacBook Pro (2009) can't upgrade to Sierra (too old). But...I saw that the software should be compatible with El Capitan, and buying a new Mac because the software of Garmin does't work is not such a good idea for my wallet... If I have an older version of Garmin Express that works fine with my Forerunner 645, it would be a second best. Anyone an idea how and where to get it?

                            Comment


                            • #15
                              I’m in a similar situation. I have an ‘08 iMac and high Sierra isnt supported. I did find a patch that enables older machines to use this newer os. Do a google search for the patch.

                              Comment

                              Working...
                              X