Announcement

Collapse
No announcement yet.

Sorry, we're having trouble communicating with our servers

Collapse
X
  • Time
  • Show
Clear All
new posts

  • #16
    Then call product support for detailed help. Solving individual errors like this via forums is nigh on impossible as it needs someone at Garmin to look at your specific account and system.
    Currently own Drive 50LMT-D, Nuvi 2508LMT-D, Nuvi 1490LMT, Nuvi 1310, Montana 650T, Etrex 20, and use Basecamp, OSM mapping
    Previously owned Etrex Legend H, Mio Navman and used Mapsource
    (please note that I am not employed by Garmin, but am a long term user of Garmin software and hardware)

    Comment


    • #17
      Same issue here. Tried all FAQ suggestions.

      Interestingly, even my iOS Garmin connect app is throwing a similar error when I try to view/edit "data fields" for Connect IQ apps. I get "Network Connection Error". This happens for both my home DSL connection (wifi) or when I turn wifi off and use my cellular data connection. Smells like a problem on Garmin's end.

      Comment


      • #18
        See my post above yours
        Currently own Drive 50LMT-D, Nuvi 2508LMT-D, Nuvi 1490LMT, Nuvi 1310, Montana 650T, Etrex 20, and use Basecamp, OSM mapping
        Previously owned Etrex Legend H, Mio Navman and used Mapsource
        (please note that I am not employed by Garmin, but am a long term user of Garmin software and hardware)

        Comment


        • #19
          I have had the same problem in association with my Vivoactive 3. It had been working fine, but for the last 3 days, I'm getting the "Sorry, we're having a problem communicating with our servers". That message doesn't suggest a local issue (which is VERY poor reflection on Garmin Express), but as noted above, it may well be a local issue. Here is the oddity. If I use Garmin Connect on my IOS phone with WiFi, I essentially get the same error if I try and do anything that requires internet. IF however, I turn off WiFi and use 4G only, it works!

          I have contacted Garmin support and the guy knew of the problem and suggested things like anti-virus and firewall, but did send a report up the line - but like everyon else - NO reponse after 2 days.

          I use AVG. I turned off anti-virus and the firewall on my PC, and still got the same problem. Obviously IOS isn't in that situation so it looks like Internet via my modem, but what? The firmware and configuration has not changed! The modem is a Fritz!Box 7490 which has been ROCK SOLID for years. I checked the ports open and it looks like Garminservice.exe and Express.exe both use TCP on 443 which is open.

          Bottom line - EVERYTHING other than Garmin Express on my (Windows 10) PC and Garmin Connect using WiFi on IOS works 100% so surely it is a GARMIN PROBLEM?

          Comment


          • #20
            If you think it's a Garmin problem call product support so they can help you, trying to trouble shoot what appears to be a router/wifi issue at your end is nigh impossible on a forum.
            Currently own Drive 50LMT-D, Nuvi 2508LMT-D, Nuvi 1490LMT, Nuvi 1310, Montana 650T, Etrex 20, and use Basecamp, OSM mapping
            Previously owned Etrex Legend H, Mio Navman and used Mapsource
            (please note that I am not employed by Garmin, but am a long term user of Garmin software and hardware)

            Comment


            • #21
              Hi SUSSAMB, note my paragraph 2: I have contacted Garmin support and the result and current status (unchanged) is noted above.

              Comment


              • #22
                Well I'd keep chasing them ...
                Currently own Drive 50LMT-D, Nuvi 2508LMT-D, Nuvi 1490LMT, Nuvi 1310, Montana 650T, Etrex 20, and use Basecamp, OSM mapping
                Previously owned Etrex Legend H, Mio Navman and used Mapsource
                (please note that I am not employed by Garmin, but am a long term user of Garmin software and hardware)

                Comment


                • #23
                  This afternoon, Garmin Express decided to work again after about 5 days of not working. This without any changes to my PC or modem, zip. This instability is not good. Still no word back from Garmin itself on the escalated issue.

                  Comment


                  • #24
                    I have just started having this issue too. I have a Fenix 5S and keep getting into the loop of 're-authentication required' messages alternating with 'we're unable to connect to our servers'. I've been through all of the FAQ and done the troubleshooting they suggest with no joy. I've submitted a ticket to Garmin customer service but, based on prior experiences, I don't expect to hear back for weeks (if ever!). It's really very frustrating!

                    Comment


                    • #25
                      Call them, it's far quicker
                      Currently own Drive 50LMT-D, Nuvi 2508LMT-D, Nuvi 1490LMT, Nuvi 1310, Montana 650T, Etrex 20, and use Basecamp, OSM mapping
                      Previously owned Etrex Legend H, Mio Navman and used Mapsource
                      (please note that I am not employed by Garmin, but am a long term user of Garmin software and hardware)

                      Comment


                      • #26
                        ...and the same problem came back again this morning. This is truly ridiculous. No system/modem changes, yet the problem ONLY on Garmin Express! I will call the local Garmin Office again about this...and suggest anyone with the same problem pester them until the issue is identified and addressed.

                        Comment


                        • #27
                          Yet I've never had that issue and I've used Express since Garmin released it many years ago now, let us know what Garmin say as it'll help others.
                          Currently own Drive 50LMT-D, Nuvi 2508LMT-D, Nuvi 1490LMT, Nuvi 1310, Montana 650T, Etrex 20, and use Basecamp, OSM mapping
                          Previously owned Etrex Legend H, Mio Navman and used Mapsource
                          (please note that I am not employed by Garmin, but am a long term user of Garmin software and hardware)

                          Comment


                          • #28
                            The problem continues so I rang Garmin again and they said that they would send the details to the USA and that there have been problems with Garmin Express. Apparently the USA office was working on a fix. They said they would get back to me when they had a solution. So far, I have removed and re-installed Express, factory reset the VivoActive 3, set no proxy, tried my old VivoActive HR (same problem). No problems when using with Garmin Connect on my iPhone.

                            Comment


                            • #29
                              Received a new Fenix 5X as a replacement for my faulty Fenix 5 and Garmin Express keeps showing an error message saying that it can't connect to servers, I never saw this once with the other watch. Can anyone assist? TIA
                              Fenix 5X
                              Fenix 5 Sapphire Black
                              Garmin foot pod
                              Garmin Tempe

                              Comment


                              • #30
                                I've spoken with Garmin support this morning and they emailed me some steps to try and none of them have worked. Interestingly this only happens with the 5X, when I selected my old forerunner then it said that the unit was up to date (no error message) I don't even need the 5X to be connected to the PC to get the error message
                                Fenix 5X
                                Fenix 5 Sapphire Black
                                Garmin foot pod
                                Garmin Tempe

                                Comment

                                Working...
                                X