Announcement

Collapse
No announcement yet.

Error with non-existent files while uploading: "Some files could not be uploaded"

Collapse
X
  • Time
  • Show
Clear All
new posts

  • Error with non-existent files while uploading: "Some files could not be uploaded"

    I am getting an error with connect stating Some files could not be uploaded to Garmin Connect pointing to a file with a date 14th Aug 2017, 09:59 stating Invalid file but there is no file called 2017-08-14-09-59-xx.fit nor any with a created or modified date/time matching.

    From other threads on this it sounds like a corrupt file on your computer, but they all link to http://support.garmin.com/support/searchSupport/simpleCase.htm?caseId={b2320530-05f0-11e4-eaba-000000000000}&kbName=garmin which no longer exists.

    I have looked in ~/Library/Cache/Garmin and there is nothing and in ~/Library/Application Support/Garmin/Express and there is again nothing. I even removed the device from express and them made sure all the data was deleted from ~/Library/Application Support/Garmin/Express/RegisteredDevices but when I readded it the error happened again.

    Any ideas?

  • #2
    Anyone got any ideas? I have a 9 day ride coming up in less than 2 weeks and I'm really worried the EDGE is going to fail. I removed the memory card and did a factory restore and it still appears. I've noticed the time matches the time of the err_log.txt file on the device but it is empty, if I remove the file it gets recreated again and the error message changes to match the new file

    Comment


    • #3
      This isn't going to help much but here's what I've been experiencing. I'm running on a Garmin Edge 1000, sync'd to an iMac on Sierra - Garmin Express 5.5.1.0 (with an update pending - I just noticed). My Garmin Edge has been set up using files from the 810 I upgraded from, so I suspected this may be causing the "invalid file" error. On the advice of Garmin Support, I did a factory reset and the problem persisted. The "invalid files" at first were *.fit files from rides (which would still sync with Strava), but later the files became more arcane. It is useful to search in your Garmin directory for files that match both the date and timestamp - you will find it. One file, as an example, was from the debugger folder. When I reported this to Garmin Support - they asked me to send them back my Edge 1000. I did so and this morning received a new one (my old Edge was less than 60 days old otherwise I would have received a refurbished unit). First sync on a new, out-of-the-box device, and I get an Invalid File error pointing to, of all things, the "startup.txt" file which is about as innocuous as they come. I've reported this to Garmin and am hoping, when my new Edge finishes downloading and installing it's maps, that an Express update will fix the problem. Short answer - I don't think anyone really knows where these "invalid file" errors are coming from.

      Comment


      • #4
        Try plugging your Edge back in and let it mount in the finder. Then empty your trash and eject the edge. Then plug back in and try to sync. Sometimes Garmin Express will choke because a file is listed in the file system, but it's actually in the trash so it can't be accessed.

        Comment


        • #5
          I have the same problem. The date and time for the "invalid file" changes each time I sync and matches the time of the last sync so I know it is not an actual file. Right now it says: 2017/09/04, 08:46 (Invalid File). I have not had a ride since yesterday but I just plugged the 1000 into my mac.

          Yes, I have emptied my recycling many times. I have also done a factory reset on the 1000 and removed and reinstalled Garmin Connect. That was the biggest mistake. The problem with my 1000 persists and now Garmin Connect fails to save some information for my 1030. I have to re-add the 1030 every time I want to use it with Garmin Connect. It seems to have an issue with the network information, but I am not sure.

          Basically, I think Garmin Connect is very broken and it would be nice if we could roll back to the previous version.

          Comment


          • #6
            I think I finally fixed it. My Garmin 1030 was not appearing in Garmin Express and my 1000 was constantly reporting the "invalid file" issue with the date and time always matching the time of the last sync. In looking at the logs in ~/Library/Application\ Support/Garmin/Express/Logs, I found that it was having an issue with the Weight.fit file on my 1000 and that the GarminDevice.xml for the 1030 was corrupt. I copied the GarminDevice.xml from my 1030 into the appropriate RegisteredDevices folder (replacing the almost-empty file) and I removed the Weight.fit file from the Garmin 1000 (/Volumes/GARMIN/Garmin/Weight/Weight.fit). Garmin Express now launches and syncs all three devices correctly. I have re-lauched and synced a few times without the invalid file issue resurfacing. It does keep re-installing some update, but it succeeds every time now.

            Comment


            • #7
              I'm having the same issue. I'm not able to locate the invalid file. Tried searching in garmin actives or in Mac folders. Anyone has a solution?

              Comment

              Working...
              X