Announcement

Collapse
No announcement yet.

VivoActive 3 Sensor Permssions

Collapse
X
  • Time
  • Show
Clear All
new posts

  • VivoActive 3 Sensor Permssions

    Playing around with sensors, setting

    Code:
    Sensor.setEnabledSensors()
    always throws

    Code:
    Permission required
    Failed invoking <symbol>
    Permission Required
    With either available sensor.

    Code:
    function initialize() {
      WatchFace.initialize();
      Sensor.setEnabledSensors( [Sensor.SENSOR_HEARTRATE, Sensor.SENSOR_TEMPERATURE] );
      Sensor.enableSensorEvents( method( :onSensor ) );
    }
    Setting every possible permission changes nothing, I assume somewhere in the simulator you have to accept the permissions? But I cannot for the life of me find where.

    Code:
    <iq:permissions>
      <iq:uses-permission id="Ant"/>
      <iq:uses-permission id="Background"/>
      <iq:uses-permission id="Communications"/>
      <iq:uses-permission id="Sensor"/>
      <iq:uses-permission id="SensorHistory"/>
      <iq:uses-permission id="UserProfile"/>
    </iq:permissions>
    Last edited by Handsomerob; 12-29-2017, 01:37 AM.

  • #2
    This is really a question for the Connect IQ Developer Forum.

    For watch faces, you can only use Sensors in the background process (same with Comm and Ant).
    My Connect IQ Apps in the Store
    Facebook - Instagram -
    Twitter

    Comment

    Working...
    X