VA3 + F5 FW bug! ActivityInfo.currentLocation drifts away 10s of km per day

Hello, I am debugging my Weathergraph watchface on VA3, and I found that the location provided by Activity.getActivityInfo().currentLocation drifts away over time by 10s of kilometers per day on Vivoactive 3.

The drift starts from a real location of last activity, but then a fixed offset over time is added, so that after a day without GPS lock watch returns a location that might be 50 km away - and I get reports that app is showing weather for a wrong location.

Locking GPS returns the location back to my real location, but then it starts to drift again in a seemingly random direction and speed again.

I logged locations returned by ActivityInfo and visualized it on the map, please check the attachment.

This seems like a serious bug in a GPS firmware.

SW versions:
Vivoactive 3 silver
SW 5.50 (latest available)
GPS version 2.30
TSC 2.10
Sensor 6.00
WHR 20.03.31
CIQ 3.0.3 community.garmin.com/.../1428858.png
Parents
  • tomaskafka Like Jim has said, we have seen this before on the VA3. The fix is in progress but it has not been released yet. We did not know however that this is also found on the fenix 5! Thanks for bringing that up. I did successfully reproduce it on a Fenix 5 and I will start the ticket
    Have you only got reports for this on the Fenix 5? how about 5s, 5s+, 5+, 5x, or 5x+?

    Thanks
Reply
  • tomaskafka Like Jim has said, we have seen this before on the VA3. The fix is in progress but it has not been released yet. We did not know however that this is also found on the fenix 5! Thanks for bringing that up. I did successfully reproduce it on a Fenix 5 and I will start the ticket
    Have you only got reports for this on the Fenix 5? how about 5s, 5s+, 5+, 5x, or 5x+?

    Thanks
Children
No Data