PDA

View Full Version : Problem with Garmin Express



05-01-2013, 03:37 AM
Hi,

Once I install and run Garmin express it blocks all my named pipes services and I experience many issues with my other software. My Visual studio test runner does not executes the tests and my Telerik JustCode extension is blocked too.
Please take a look and fix this.
Thanks.

Graf von Monte Christo
05-02-2013, 03:09 AM
I am having the same issue on both my laptop and my HP workstation. As soon as Garmin Express is unistalled, named pipes work again. Please fix this ASAP.

Graf von Monte Christo
05-02-2013, 03:13 AM
http://www.verious.com/qa/3rd-party-app-breaks-our-wcf-application/

http://stackoverflow.com/questions/16020706/what-might-cause-endpointnotfoundexception-on-local-wcf-named-pipes

This issues is causing real pain.

VinayKrishna
05-05-2013, 10:24 PM
+1
This is causing a lot of apps dependent on named pipes to break - particularly the Visual Studio Unit Test features. We at Microsoft have zeroed down the issue to the way Garmin Core Update Service creates named pipes. Named pipes can be created in different Scopes – Global and Local. Global scope is essentially machine wide and Local is specific to the user.
Garmin’s application is
a. running as System service, so the scope for listening named pipe service is global.
b. listening on the root address of “net.pipe://localhost/” (e.g. without any sub-paths/segments).
c. Using a StrongWildcard host name comparison mode.
d. Items a through c mean that Garmin’s application is essentially a catch-all for any net-pipe connection that doesn’t match something more specific.
e. It also means that Garmin is completely blocking all listeners that are using a local scope

The fix for this would be to change Garmin application such that it registers its net.pipe listener with a more specific url.

mr_nat
05-17-2013, 07:04 AM
This will be fixed in an upcoming version, due out later this month. Apologies for the inconvenience.

PDF61
05-17-2013, 03:27 PM
Forgive me if this is out of place on this thread and my technical ignorance but do I understand that Garmin Express has a problem only I have issues with Garmin over the latest updates to my Zumo 550 (case number 1960073) such that up until I loaded 2013 earlier this year with Garmin Express I had a perfectly good working device, then having loaded 2013.40 with G.E. I found out whilst in Holland that the use of any of the Address functions switched the device off plus the use of the SD card caused problems.

Several attempts to remedy this with assistance from various Garmin technical support people including using the old downloader to load 2013.41 was to no avail and eventually led to my device having to be returned for replacement due to what I can only describe as chequer-plate mapping areas plus a "Splash screen" fault; another 111.31 ($150 ?) down the drain.

When the refurbished unit arrived I checked the mapping and found that it was 2010???? I tried naturally to update the mapping (I have lifetime update) with the old downloader as I didn't trust G.E. but it would not load due to the omission of a required previous download (presumably 2013) so I resorted to using G.E to load the 2013.41 maps on my computer only (remember I don't trust G.E.) but after several hours was informed that some updates failed to complete; "Rety" or "Ignore" boxes were present, I tried retry 3 times then went no further and contacted Garmin Support again with a photo of the error box plus copies of Setup log XP and GarminDevice.xml. That was some days ago and I have yet to hear further.

Furthermore in registering this refurbished device and checking my available maps for download I noticed that there were several previous download attempts all of which were unsuccessful; I again contacted technical support to pass this information on.

In the meantime having had what was a perfectly good device ruined (in my opinion) by this latest mapping update fiasco with G.E. I lodged a formal complaint but as yet have had no acknowledgement of such which I am not happy about.

Sorry for being long winded but as I am going abroad next month I need to get my device up to date and working properly A.S.A.P. but if it is a serious fault with G.E. then I will make do with the current 2010 mapping and hope for the best.

STUARTMW
05-17-2013, 03:42 PM
Several attempts to remedy this with assistance from various Garmin technical support people including using the old downloader to load 2013.41 was to no avail...

The usual solution is use GarminMapUpdater (http://download.garmin.com/lmu/GarminMapUpdater.exe) instead of GE. I assume that's what you meant by "the old downloader". If so the only solution I can propose is to try an old version of GarminMapUpdater using Google or some other search engine. On one machine I have to use 3.0.11 instead of the latest (3.2.2).

PDF61
05-18-2013, 03:08 PM
Yes, that is what I meant however with using GarminMapUpdater I come to a dead end when I am told that it can go no further due to a previous version not being loaded and it then finishes. Maybe I will do as you say and try a much older version of MapUpdater.

Thanks.

STUARTMW
05-18-2013, 03:19 PM
Ahhh. Others are seeing the same on older models.

Garmin Map Updater v3.2.2 Error Message (https://forums.garmin.com/showthread.php?38383-Garmin-Map-Updater-v3-2-2-Error-Message)

Perhaps Garmin's map update servers are having issues.

06-05-2013, 12:54 AM
This will be fixed in an upcoming version, due out later this month. Apologies for the inconvenience.

Is there any update on when this patch will be available? This issue is causing problems for a couple of our applications.

06-20-2013, 06:57 AM
Hi. Bumping this. It has been about a month since the 'later this month' comment.

Any update on when a new version is going to be in the pipe so we can let our customers know?

STUARTMW
06-20-2013, 07:21 AM
https://forums.garmin.com/showthread.php?35690-Garmin-Express-2-1-13&p=188079#post188079

06-20-2013, 08:16 AM
Secret download link! Thanks. Installing that version does indeed fix the problem.

09-10-2013, 12:38 AM
Hi same problem as you, only had device for 4-5 months but always get error messages when completing updates. When downloading latest map updates (2014) unit lost all saved info such as "favourites", "map themes". language select and unable to connect with Iphone anymore, not to mention cannot use Voice Command, rang Garmin several times with different solutions which never worked, now have returned unit for a replacement one, still waiting weeks due to no stock available. Don't get me wrong I loved the device when it was working but having to use Garmin Express worries me totally for future map updates, and whats going to happen when the warranty expires am I expected to pay for repairs even if it's Garmin Express which has caused the faults. Wish I knew this before purchasing a Garmin.

SUSSAMB
09-10-2013, 12:47 AM
Do what many of us do, use GarminMapUpdater for PC (http://download.garmin.com/lmu/GarminMapUpdater.exe) instead :)

Mac version is here GarminMapUpdater for mac ( http://download.garmin.com/lmu/GarminMapUpdater.dmg)

Having said that the latest Express versions seem better at updating software and installing maps, from posts I've seen elsewhere.

09-28-2013, 12:12 PM
I found using the Garmin Map Update did the trick.

09-28-2013, 12:38 PM
Please could someone help me, I have purchased north america maps its in my maps area but when I download it opens express and its not there for to update onto my Garmin Nuvi2515, please help we fly to the states tomorrow and I have no GPS!!