View Full Version : Does Virtual Racer work?

10-26-2012, 12:12 PM
Tried Virtual Racer for the first time yesterday. I downloaded the previous day's 10 mile run to use. I selected it in the Virtual Racer function and selected Do Workout and it took about two minutes to load. I selected the screen that shows the little people icons and pressed Start to start the run.

As best I can tell, one of the little icons never moved. The "Time Ahead" or "Distance Ahead" (Sorry, I don't have the watch with me here to look at.) stayed at zero. After a quarter mile or so, one little man was off the screen (having gradually shifted to the left) and only one was remaining.

I intentionally started this run about 30 seconds of pace slower than the comparison run, and finished up with an average that was 30 seconds faster. So, there should have been some difference in representation on the watch. Nothing ever changed. There was just the one little icon showing in the display, in the center between left and right, and the shown numbers were 0.00 or 00.0 or some such.

I did get a notification a minute or two before I completed the 10 miles that something had finished, but I don't exactly remember the message now. Anyway, it knew that there was a Virtual Racer scenario happening.

So, did I somehow screw something up, or is this just another Garmin feature that doesn't work?

10-26-2012, 02:26 PM
I've used mine a few times now and it seems to work ok.
I have a course i run that has .25 mi warm up so plenty of time to get a satellite lock and the watch to get itself in order. I always start at the same place (a manhole cover on the pavement) yet sometimes the watch gets confused at the start and put's me 10-30 seconds behind or ahead even when i have only run a few paces, seems to sort itself after a while.

Sound to me like you screwed something up i'm afraid.

10-30-2012, 08:31 AM
After doing some more Googling around, it seems that people have problems with Virtual Racer with longer runs. It seems to work ok for short runs. Don't know where that dividing line is. I use one second recording, but don't know if that matters. It does make for more data points though.

Another post that I saw had symptoms the same as mine for a longer run. Unfortunately, I rarely run short runs. I had a 310xt and only got the 910xt for the Virtual Racer feature and the barometer, and both of these features have issues.

11-05-2012, 06:35 AM
Tried it again and it definitely doesn't work for a 10 mile run (recorded with 1 second recording option.) I'll need to call them to put in a ticket. I just dread calling these help centers. I've never found anyone who knew what (s)he was talking about.

11-08-2012, 07:08 AM
Another update. Tried it on the treadmill this morning in a four mile run using a foot pod against another four mile treadmill run from a couple of days ago. The results are slightly different.

This time, the Virtual Racer screen did show me the distance I was ahead (or behind), which was always equal to how far I had run. The top icon moved off the screen to the left as with the longer runs. The time ahead was still always zero.

I'm not sure which icon is supposed to represent the other run and which icon is supposed to represent me.

I'll go out for a couple mile run in a couple of days, the day before my marathon and try Virtual Racer again comparing to another similar run. So, this one will be a shorter outside run.

11-13-2012, 06:05 AM
Tried Virtual Racer on a short run (about 2 miles) and it worked as expected. So, the issues are with foot pod runs and with longer runs.

11-13-2012, 10:40 AM
Just to check .... you did run exactly the same route did you?

Virtual Partner was always just a time based thing I think, you set the speed / pace / time and it lets you know how far behind or ahead of that you are.

I think Virtual Racer might plot where you are via GPS and tell you how far ahead or behind you are from when you ran that same course previously, I am not sure it works if you are on a different course.

11-13-2012, 10:49 AM
The 10 milers that didn't work were on the same course. The 2 miler that DID work was on a different course. So, it must just be keeping distance metrics and not gps locations.

01-31-2013, 12:23 PM
Just an update on this.

Just got off the phone with Gamin Support and they downloaded a 10 mile run of mine and were able to replicate the issue. They said they hoped to get back to me in a couple of weeks. At least they recognize that there is a problem. Just hope they can get it fixed.

03-23-2013, 06:31 AM
Any news?

Next week I am running a hilly halt marathon, and I would like to use VR. I have already download the race course at the target final time, and upload it into the watch (FR 610).

I have given today a try in my 16km run, comparing with previous activities, and exactly what you guys say... 00 time and distance ahead :confused: and only one of the two stick man was on the watch.

BTW, I was wondering if VP needs to be enabled for VR to work... It was not enables when I have used it.


03-23-2013, 10:56 PM
This hasn't worked for a very long time. I am disappointed they haven't fixed it yet.

03-25-2013, 08:45 AM
Any news?

BTW, I was wondering if VP needs to be enabled for VR to work... It was not enables when I have used it.

No new news, but I never expected Garmin to actually get back to me like they said they would. I would have been shocked if they had. The next device update either will or will not have the fix. Even if they get a fix they may just wait for a new device to put the fix into, instead of fixing the existing device.

I always have to muck with this thing when I try to use it again because I always forget how to set it up. Yes, I think VP needs to be enabled but to tell you the truth, I just don't remember at the moment.

07-22-2013, 06:23 AM
Tried it again for a 10 mile run after the 2.80 firmware upgrade and it still doesn't work.

07-22-2013, 12:37 PM
Called up Garmin support about this issue again and asked for the original bug number. Person said he couldn't get it and couldn't look up the original bug even though I gave him the exact date (01/31/13). He didn't seem terribly interested. He took the information again and said he would look into it. Yeah, right. Maybe I'll just start calling them daily.

07-23-2013, 02:13 PM
I just found a thread from March 2012: https://forums.garmin.com/archive/index.php/t-26071.html

There is a message in there that said that Garmin had told the user to change the name of the activity to RI0001 and then download it into his Garmin. He did and then it worked, even though it was a long run (25 km). I just tried the renaming trick and it did indeed work. Who'd a thunk?

To Garmin's credit, the person I talked to yesterday actually did send me an email asking me to write up the issue more fully and to send it to him. I did so and then also sent him this workaround that I just mentioned above.

06-29-2014, 04:09 AM

On my Forerunner 610 the virtual racer doesn't seem to work on distances more than about 3.5 miles. I tried the above fix RI0001, and the function now works slightly better, a second man has now appeared, but the distance ahead/behind still always reads 0. Any ideas?

Incidentally, I can't change the activity name to RI0001 on my watch without having a lowercase 'i'. Do you reckon I need to change the activityt nae on garmin connect?

So frustrated Garmin have never released a proper update for the virtual racer, they seem to have ditched the feature on their more recent watches too.

07-01-2014, 12:27 PM
I have always changed the name of the workout in GarminConnect and then downloaded. Actually, I thought it was an upper case "I."

I only tried one test after having changed the workout name on Garmin Connect and it was for a bit over 10 miles. It worked as expected. I haven't used it again.

I already had a 310xt and the only reason I bought the 910xt was for this Virtual Racer feature. Their refusal to fix this feature, when it was one of the only differentiating features from the 301xt, has cost me any trust with that company. I won't be buying any more of their products.

06-08-2015, 04:34 PM
Hi guys

In first place, sorry for my english. I hope that you understand me.

I have saw now this old thread with the issue of Virtual Racer of Garmin. I have bought a 910XT recently and I have the same problem. But I think the problem is when you download a activity from garmin connect, or from de PC program Training Center, to your garmin device.

When I do this, the Virtual Racer never work, but if I load in Virtual Racer activities from Garmin itself (before deleting them from the device) always work, with short distances, long distances, with run activities, cicling activities.....

I have stored several racing in my Virtual Racer in this way. Before I delete the activity I load it in Virtual Racer and after I delete it from activities, but it remains stored in the Virtual Racer and I can compete against it others days. But...... I konw, the memory of device isn't infinite...

I think that the problem is this. The download of activities from a external source doesn't work fine, and the Garmin device doesn't load the data correctly.

But, I haven't got solution for this..:mad:

Best regards

06-25-2015, 02:19 PM

If you want to delete old courses on your watch, you have to delete it on the watch and on your computer. On a window pc you have to delete the files on your user directory (hided!) : C:\Users\*YOURUSER*\AppData\Roaming\GARMIN\Devices\*YOURDEVICENUMBER*\Courses.

To optimize memory is bether to reduce the nr of points on gpx tracks with gpsbabel or on gpsvisualizer.com website. To upload the gpx file on the watch I use www.tcxconverter.com.