PDA

View Full Version : Unable to use MapInstall: "An error occured while building the map"



POILKJH
09-16-2009, 02:08 PM
Hi,
I'm using the latest version of MapInstall on my macbook with MacOS 10.6.1. I'm trying to get the map "Topo Deutschland V3" on my Etrex Vista HCx. The map as well as the Etrex work perfectly fine on the Mac. I can use Roadtrip to view the map and also load track-logs from and to my Garmin device. When it comes to MapInstall I can also see the the device and the map and I'm able to select parts to upload to the Garmin. But when I try to transfer the map to the connected device I get the following error:

http://img182.imageshack.us/img182/4743/errorfz.th.jpg (http://img182.imageshack.us/img182/4743/errorfz.jpg)

I already tried to use a cardreader to copy the map-files to the SD-card and reformatted the card with FAT32 to no avail. But to be honest, I didn't really expect these steps to help, since the error seems to occur before MapInstall even attempts to transfer the map (maybe 2 seconds after clicking the transfer-button).

GEORG-L
09-20-2009, 01:45 PM
"Topo Deutschland V3"

Same here: Will not install in micro sd card for Garmin Edge 705.
Snow Leo 10.6.1, MapInstall 2.1.0.
:confused:

SAEEDI
09-20-2009, 01:50 PM
Same here: Will not install in micro sd card for Garmin Edge 705.
Snow Leo 10.6.1, MapInstall 2.1.0.
:confused:

Did you create a "Garmin" folder on the SD Card?

GEORG-L
09-20-2009, 01:52 PM
Did you create a "Garmin" folder on the SD Card?

No. Is this mandatory for it to work?

POILKJH
09-20-2009, 02:12 PM
It seems to be broken for "Topo Deutschland V2" as well. Friend of mine uses this version on Mac OS 10.5.8 with an Vista HCx. Same error.

SAEEDI
09-20-2009, 02:20 PM
No. Is this mandatory for it to work?

Can't hurt to try, especially with a new card.

GEORG-L
09-23-2009, 08:25 AM
Can't hurt to try, especially with a new card.

Tried it and made a folder called "garmin" on the card->still no luck.
Both of my macs don't even get that far on writing to the card.

I guess I have to fire up the Windows PC again to install maps. What a pain… :mad:

POILKJH
09-23-2009, 03:14 PM
Both of my macs don't even get that far on writing to the card.


Yes, that's exactly what I observed. I think the error message is pretty precise - the error occurs while compiling the map data not during the transfer to the GPS device.

@GEORG-L: Did you ever write to the garmin support?

BUCKM56
10-03-2009, 09:30 AM
I'm having what seems to be the same problem on Mac OS 10.5.6. I bought a new SD card (4 gig) and have connected directly to the USB port. I have been successful loading only the Colorado and Utah portion of Topo 2008, but I want to load the majority of the US since I'll be traveling extensively this year. First the message says this will take approx 2.16 hours to complete but it kind of sticks there. I let it run all night and this morning there was a messages saying there was an error.

I wonder if there may be some corruption on some section of the TOPO 2008 causing the problem or something in the conversion of the Windows version of Topo to the mac usable file?

Anyone fix their problem?

THanks

GEORG-L
10-04-2009, 03:53 AM
tried the same procedure under parallels with mapsource and the 4GB SanDisk MicroSD Card and all transfered flawlessly.

I assume that there is a problem with cards bigger than 2 GB and the Mac Application GarminMapInstall

Is somebody from Garmin Tech Support out there who is willing to reproduce the problem and try to fix it?

RUETTIGARMIN
10-04-2009, 01:45 PM
I have the same problem. Since upgrading to MacOS X 10.6, I am not able to update the maps on my StreetPilot 510c. I downloaded the latest European Map Update two weeks ago and was not able to install it. I had to switch to windows (boot camp) in order to install the map.

Arturus
10-15-2009, 04:56 PM
I hate to say this but - "me too". I am trying to use Mapinstall on a PowerMac with 10.6.1 and a Garmin 60Cx and it gets almost to the bit where it starts to copy the map file over to the memory card before crashing with an error. Can Garmin please fix this asap?

Thanks

GEORG-L
10-16-2009, 01:40 AM
PowerMac with 10.6.1

Sorry, but those two, do not work: 10.6.1 does not run on a PowerMac.

BSHROPE
10-28-2009, 05:15 AM
I'm having the same problem. What seems to work better is to select and load areas no bigger than a U.S. state or maybe two. l tried to load the whole U.S. first go and it broke down so I tried roughly just my home state of Washington and it worked. Loaded Oregon and Cali next no problem. Then I tried the whole midwest and it crashed with the same error. It says dumb things too like it crashed while building the image when it clearly had completed building the image and was in the transferal phase. Again I tried to load a smaller image and it worked.

Definitely a seeming correlation between the size of the maps I'm trying to load and the probability of failure. This friggin program is taking upwards of a day sometimes to complete also... It's a buggy program right now, I hope there is some bright people working on it!

FIRE_STROM
10-29-2009, 02:56 PM
Same sort of deal with US Topo 24k Southwest. Cant do the whole thing at once and haven't been able to do it piece meal. Mac 10.5.8. I guess I could open Fusion and do it from the PC side but I thought we were over that.

GEORG-L
10-30-2009, 02:14 AM
Jep. Did it with Parallels and WinXP on my Mac. Installed fine with MapInstall on PC. Conclusion: The problem is not with the map data but with the Garmin MapInstall 2.1.0.
Somebody listening @GarminHQ? :confused:

LIPKOWIT
10-30-2009, 09:32 AM
We are looking into what is causing this issue, and we will provide more information as we get it.

RUETTIGARMIN
11-17-2009, 06:26 AM
Hello,

So what's up? We are all unable to install any update we have bought from Garmin to our devices. One month (close to) is over now since the last message from Garmin ...

Regards,

Cyrill

PEELSTER
11-18-2009, 11:05 AM
I'd post a new topic to get some attention on this, but nobody likes that. I have a brand new Oregon 550, a mac book pro with Leopard (haven't upgraded to SL yet), and a brand new DVD with CN North America NT 2010. Much to my chagrin I have not been successful in loading my maps onto my Oregon. I will try the "one state at a time" route, but that is really unacceptable. Has anyone (Garmin ... anyone) figured out the root cause and potential solution to the problem? My error message is identical to the one posted several posts up. Thanks.

azdrmn
11-19-2009, 04:13 PM
The 2GB problem has been found and fixed and will be released in an upcoming update of MapInstall. In the meantime, if you manually limit the size of the files selected for transfer to the device to 2147 MB, it should work. Sorry for the inconvenience.

Note that even with this fix, there is a 4GB limit, as this is the device's limit for supplemental maps.

azdrmn
11-24-2009, 01:14 PM
We've released MapInstall 2.1.2 beta that fixes the 2GB limit. We decided to go ahead and release this version so users can get around this limit, while we continue to work on an official MapInstall release. You can get the beta here (http://www8.garmin.com/support/download_details.jsp?id=4729).

GEORG-L
11-25-2009, 12:47 AM
We've released MapInstall 2.1.2 beta that fixes the 2GB limit.

Thank you! :)
Please do the same with RoadTrip so I can go ahead and order a new mac for christmas. :rolleyes:

POILKJH
11-27-2009, 09:08 AM
We've released MapInstall 2.1.2 beta that fixes the 2GB limit. We decided to go ahead and release this version so users can get around this limit, while we continue to work on an official MapInstall release. You can get the beta here (http://www8.garmin.com/support/download_details.jsp?id=4729).

Did I get that right that this release is NOT supposed to fix the "error coccured while building the map" issue? Because I just downloaded the beta release and for me nothing changed. I'm still not able to transfer maps to my Vista HCx :(

azdrmn
11-28-2009, 12:55 PM
Did I get that right that this release is NOT supposed to fix the "error coccured while building the map" issue? Because I just downloaded the beta release and for me nothing changed. I'm still not able to transfer maps to my Vista HCx :(
This release does fix some issues that have been reported through the crash reporter. If you are still experiencing issues, please report it and be sure to attach the logs as instructed. More than 90% of the crashes reported have no logs attached, which means we can't really do anything to help.

RUETTIGARMIN
12-02-2009, 02:28 PM
In my case, no logs are written. When I fire up Console, there is no log file entry in the folder garmin.

REMAGI
12-04-2009, 12:17 PM
MapInstall 2.1.2.1 beta is now available. If you experiencing the "error occured while building the map" issue, update to this beta and follow the instructions on this post (https://forums.garmin.com/showthread.php?t=3983).