PDA

View Full Version : 310xt - 2.60 firmaware upgrade



POSITIVPAU405
08-31-2009, 08:38 PM
It does not work for me. Ant keeps trying to install the firmware but it always fail. It was always able to transfer my activities and settings without any problems.
My 310xt is version 2.5 (not 2.4). Could that be the issue?
I'm running Leopard and the Ant Mac version (latest)
Any help would be appreciated.
Best,
positiv

SJSTRAW
09-01-2009, 05:02 AM
Same problem here, I think this might be a snow leopard issue. Lets wait and and see.

Also when I plug the USB stick in it now says the following;

--------------
A new network interface has been detected. The "Dynastream ANT2USB" network interface has not been set up. etc etc etc...
--------------

It never used to do that under Leopard. Again, only since Snow Leopard.

PUFFOLINO
09-01-2009, 05:32 AM
Had also 2.5 on the FR310, update worked fine here with WinXP - but you have to be patient...
...uploading via ANT seems to be quite slow (compared to the USB-connection we had with the FR305)
...after the upload the device does the update which takes also quite a while (so try to have freshly loaded the batteries;)
...of course all trainings, courses and individual settings are gone after the update*

Michael

*) a backup/restore tool for the main settings would be fine, especially because I had to change the metric/static settings two times after the update, who knows why

If something like that will never come, what about the following help for us all: allow copying the data field screen settings from one sport type to all others?!

SJSTRAW
09-01-2009, 09:46 AM
Ok I have now tried updating to 2.6 the following ways;

Windows XP running in Parallels 4 for Mac - XP does not recognize USB device (ANT USB).

Windows 7 running on Acer PC - Uploads and connects to Garmin connect, downloads new firmware, does NOT install on 310 device.

Mac OSX Snow Leopard - Connects, uploads events etc, downloads new firmware but keeps hanging on 0% Transfer Status, then 310 watch reboots, over and over again. Message is - Last transfer with device Forerunner 310XT on XX-XXX-2009 at XX:PM was successful, but the firmware update failed.

Any pointers? Anyone?

Good luck.

SAEEDI
09-01-2009, 10:10 AM
Mac OSX Snow Leopard - Connects, uploads events etc, downloads new firmware but keeps hanging on 0% Transfer Status, then 310 watch reboots, over and over again. Message is - Last transfer with device Forerunner 310XT on XX-XXX-2009 at XX:PM was successful, but the firmware update failed.

I assume you're using GAA 2.1.3. What version of firmware on the 310XT are you upgrading from?

SJSTRAW
09-01-2009, 10:20 AM
I assume you're using GAA 2.1.3. What version of firmware on the 310XT are you upgrading from?

Hi thanks for your interest.

I am using the most up-to-date of everything. Yes GAA 2.1.3, that was all installed along with the new OS (Snow Leopard), not even 48 hrs ago.

My 310XT currently is running on I believe 2.5.

Thanks again.

SAEEDI
09-01-2009, 10:29 AM
The option of last resort may be to downgrade GAA to 2.1.0 for updating the firmware and then go back to 2.1.3 upon successful firmware update.

I'm not sure how Snow Leopard will work with the previous GAA.

philipshambrook
09-01-2009, 10:57 AM
Running Snow Leopard now, but not yet tested the beta ANT Agent. However, ANT runs fine in Vista under Parallels after reloading ANT Agent, re-pairing and re-authorising.

As posted earlier, if you have run ANT on the Mac you need to open a terminal window and run

Sudo kextunload /System/Library/Extensions/SILabsUSBDriver.kext

before running ANT in parallels.

SJSTRAW
09-01-2009, 11:23 AM
The option of last resort may be to downgrade GAA to 2.1.0 for updating the firmware and then go back to 2.1.3 upon successful firmware update.

I'm not sure how Snow Leopard will work with the previous GAA.

Thanks for the suggestion. Actually I don't know where to get the older version, but from what I've read, the updates from 2.0.0 to 2.2.2 and 2.1.3 are all accumulative. So if it worked in 2.1.0, it should work in 2.1.3.

I can only assume this is a Snow Leopard issue, because we aren't really getting confirmation from Garmin that there is an issue - so I guess I'll just wait to see how many others, if any at all, suffer the same set back that I have. Fortunately, I was quite happy with the system on 2.5 already.

SJSTRAW
09-01-2009, 11:46 AM
Sudo kextunload /System/Library/Extensions/SILabsUSBDriver.kext

before running ANT in parallels.


Hi Phil,

This helped to get Parallels to recognize the USB ANT. But it did not resolve it completely. For some reason it was unable to then pair with the 310.

I must add though that I am trying everything. Most ppl out there will be working with one OS platform, not 3. Ideally, it would be first prize to get the GAA running natively on Snow Leopard, and not through Parallels.

That also said, if I can get it to work through Parallels I'll be relieved. Still trying, still failing, will press on tomorrow.

Thanks for the advice.

philipshambrook
09-01-2009, 03:13 PM
Probably a silly question but did you delete your device, then re-pair?

Also forgot to mention (not sure how much effect it might have) that apparently the ANT key should be unplugged before running the command in Terminal. I've left mine in with no problem, but you never know. I have also deleted the ANT Agent from the Mac now too. Not sure if that makes any difference - it would if you rebooted with it loaded in the Mac as you would then have to run the command in Terminal again

The reason I persist with using Windoze is because I use SportTracks more than anything else. I can then link directly to RunSaturday.com from SportTracks. I have the ANT Agent uploading to Garmin Connect, sending to GTC and deleting from the device. All is working fine since the Snow Leopard upgrade. I use GTC on WIndoze for sending workouts and as a backup data store.

Still unimpressed with GTC on the Mac despite the revamp so no incentive/reason to use ANT on the Mac. Even more so given the problems with Snow Leopard, which I've just loaded up.

Getting old!! Forgot to mention that I did have an ANT stick that worked on the Mac but not with Windoze under Parallels or direct. I sent it back to my retailer and got a replacement.

SAEEDI
09-01-2009, 03:46 PM
Even more so given the problems with Snow Leopard, which I've just loaded up.

I don't think your issues are Snow related. At least the Garmin ones.


Getting old!! Forgot to mention that I did have an ANT stick that worked on the Mac but not with Windoze under Parallels or direct. I sent it back to my retailer and got a replacement.

And did the replacement work? The Mac drivers will lock the ANT Stick so that Windows under Parallels (or VMWare) won't be able to attach to it. Using the kextunload command helps unload the driver for Parallels.

POSITIVPAU405
09-01-2009, 04:23 PM
I got it working under VMware (Virtual Windows Vista) on my Snow Leopard Mac. I was able to install the latest Ant and the firmware upgrade went through without any problems.

On the Mac it didn't work at all (As per my first post)
I'm not sure if this is a snow leopard issue or a Mac issue.

Anybody running Leopard (not Snow) able to update the firmware on the 310xt?

positiv

MADEUPNAME
09-01-2009, 04:57 PM
I got the firmware upgrade to work on a Mac running Leopard though I had to hard reset the 310 first to deal with a BadFit file in the User\Library.

Feedback on the upgrade to 2.6:

I ran with it yesterday in Run Mode and it worked no differently to version 2.4 and uploaded fine. (Elevation gain issue has not been fixed).

I swam with it tonight in Other Mode, recording laps, and it worked ok and did not create BadFit files (which it did last week) however when the workout uploaded to Garmin Connect the time of day for the workout displays as one hour earlier than it actually took place. The 310 displays the right time of day and the history on the 310 as well in GTC displays the right time for the workout however GC cuts an hour off. The 310 timezone is set to automatic.

philipshambrook
09-01-2009, 07:11 PM
I don't think your issues are Snow related. At least the Garmin ones.



And did the replacement work? The Mac drivers will lock the ANT Stick so that Windows under Parallels (or VMWare) won't be able to attach to it. Using the kextunload command helps unload the driver for Parallels.

Yes it did. It was definitely the ANT stick because we have 2 x 310XTs in the house and the other ANT stick worked fine in all situations, except Windoze under Parallels.
The issue with the ANT stick not working in WIndoze running natively and under Parallels are not related. Even the replacement stick did not work in WIndoze under Parallels until the kextunload command was issued.

NB-OMS
09-03-2009, 09:51 AM
Anybody running Leopard (not Snow) able to update the firmware on the 310xt?

positiv
I have Snow Leopard on my home computer and plain-vanilla Leopard on my work computer. The firmware upgrade has not worked on either. I am getting the same errors as the others... it tries and tries, but no love on the update. Activities transfer just fine.

I guess I need to go over to the VMware side...

D2000G
09-06-2009, 04:45 AM
I'm a Garmin newbie. If/when Garmin Support come up with an answer to this problem, how do they communicate it - via one of these forums or some other global way??

TSOURBIER
09-06-2009, 05:16 PM
I've also been unable to update my FR310 - 2.4 with Leopard and GAA 2.1.3. I tried 3 or 4 times, the last time i believe it uploaded until 80% they the GAA just vanished (crashed...) forcing the FR310 to reboot.

I resorted to doing the update from my PC and it worked just fine in the first attempt.

I had a very similar experience trying to upate a 405 previously (I haven't tried with this update).

T.

ps: it is indeed a shame that somehow the watch settings are not getting preserved (may be thru some kind of backup/restore... actually that could be a usefull feature that GC could offer. One could have several sets of settings ready to upload on the watch or save its current settings...)

CERVELO-VAN
09-07-2009, 09:08 PM
Kind of disappointed with Garmin. I contacted them last week about the firmware not downloading. They told me to let it run for several hours which I did and nothing happened. I then called again and they told me that yes, there is a problem with the download. Now its a week later and still nothing. No comments from Garmin on their website or on this forum about this issue.

CSTOLLER
10-14-2009, 08:00 PM
im also having problems with upgrading from 2.4 to 2.6 on a mac w/snow leopard and all garmin apps and plugins up to date. my data still uploads, but the firmware update fails and puts my 310xt in an endless loop of reboots and failed installs.

has garmin acknowledged this bug yet?