This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Some data could not be loaded

Since this morning I'm getting the message "Some data could not be loaded" when syncing on GCM. My Vivosmart HR+ is syncing fine on the PC and it isn't obvious that any data is missing on the mobile app. Is there some way I can find out what's going on?
  • Sometimes when I resume the GCM app, fields such as calories, steps, and sleep don't load correctly until I restart the app, but the error message seems to be specifically referring to the "weight" screen. That screen hasn't loaded any information since I first started seeing the error message in the orange bar that states some data couldn't be loaded (see attached image).

    The weight entered in my linked MyFitnessPal account does sync to Garmin Connect on the web. I just can't view that information from the mobile app on Windows. I even installed the UWP app on my desktop computer to make sure it wasn't a data connection issue with my phone, but the app on my desktop gives the same error message.


    I have the same problem with "weight" screen on Garmin Connect Mobile for Windows 10 Phone (Lumia 950) and Windows 10 PC (Desktop/UWP)!
  • I have the same problem with "weight" screen on Garmin Connect Mobile for Windows 10 Phone (Lumia 950) and Windows 10 PC (Desktop/UWP)!


    Looks like the issue is around weight as I have narrowed mine down to the only data I can see missing is weight. I would not be surprised to see Garmin has changed something they are doing in the background with they way they handle weight data and we would need a version bump which probably won't happen.
  • Same issue here weight is not displayed in app. Issue started a week or so ago after a weight measurement. Garmin pls fix.
  • I too have been having the weight display issue, been about 3 weeks for me, and I get the some data cannot be loaded. Not sure if it has a relevence but I am not able to update my weight from my phone, keeps saying "error occured while trying to save changes" I am on a Windows 10 950 phone that worked fine before. Never got connect to work on my motoG5plus. Hope Garmin are watching this forum .
  • After syncing yesterday it seems to be working again. Anyone else can confirm?

    If fixed, then definitely this is a very good news and big thank you Garmin!

    It may be that there's still hope. :)
  • The Pew Research data collection in mid-2014 compiled information on the permissions that Android apps required users to agree to as a condition of use. These might include simple hardware permissions for example, allowing an app to adjust the volume of a users’ phone.