This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Some data could not be loaded

Since this morning I'm getting the message "Some data could not be loaded" when syncing on GCM. My Vivosmart HR+ is syncing fine on the PC and it isn't obvious that any data is missing on the mobile app. Is there some way I can find out what's going on?
  • It happens. Probably some maintenance in the Connect cloud. It should go away after a while.
  • I have been having the same issue for a few days too. Happens both on my Surface and my L950. Activities sync but it appears daily data (Steps, Sleep etc) does not even though it says the sync was completed. As such daily data is not shown. Anyone else having this issue? Is it just Windows UWP or does it affect other platforms? Does anyone know of a work around other than cable sync via PC (which I am yet to do)? I tried uninstalling and reinstalling app but no change.
  • I haven't been able to properly sync for months losing data. Reset my phone now I can't even connect my device so I have been using Garmin Express (which the latest 6.0 takes forever to load and doesn't always detect my device). I still use the phone app to review data and now this "Some data could not be loaded." message all the time. I get steps, sleep, stress, and activities but not weight.
  • #Astranomical: I've noticed this behaviour from time to time. It's not been consistent but I notice that when it does happen once you've synced via cable this seems to fix it. It's as if it won't update the display of any field in GCM for which the data entry is a null value. Once the data is present it then updates ok.
  • #BlackScarab: Yes, the app can be utterly infuriating like that. I've found that if it refuses to connect I can usually fix it by going into "All Settings", "Devices", "Bluetooth & other devices", clicking on your device and selecting "Remove device". If that fails the next step is to go to GCM, go to Devices in the drop down menu. Press and hold your device and click "Remove". Personally I've found that you have to keep checking the bluetooth devices as if the phone has made the BT connection then GCM will never complete the device set up. I had this a lot when I first got my VivoSmart HR+ but thankfully it seems to have settled down lately.
  • I came here to see if anyone knew what is going on with this issue? I've been seeing this error message for what seems like 2 weeks, but maybe just the past week.

    Sometimes when I resume the GCM app, fields such as calories, steps, and sleep don't load correctly until I restart the app, but the error message seems to be specifically referring to the "weight" screen. That screen hasn't loaded any information since I first started seeing the error message in the orange bar that states some data couldn't be loaded (see attached image).

    The weight entered in my linked MyFitnessPal account does sync to Garmin Connect on the web. I just can't view that information from the mobile app on Windows. I even installed the UWP app on my desktop computer to make sure it wasn't a data connection issue with my phone, but the app on my desktop gives the same error message.ciq.forums.garmin.com/.../1302841.png
  • #Astranomical: I've noticed this behaviour from time to time. It's not been consistent but I notice that when it does happen once you've synced via cable this seems to fix it. It's as if it won't update the display of any field in GCM for which the data entry is a null value. Once the data is present it then updates ok.


    Yes, I worked this out last night! For the most part it worked - took 2 goes to for it to resolve the issue. But just a day later it has reverted to the same error again. There is clearly something that happens on at BT sync that doesn't on a cable sync (or vice versa).

  • I came here to see if anyone knew what is going on with this issue? I've been seeing this error message for what seems like 2 weeks, but maybe just the past week.

    Sometimes when I resume the GCM app, fields such as calories, steps, and sleep don't load correctly until I restart the app, but the error message seems to be specifically referring to the "weight" screen. That screen hasn't loaded any information since I first started seeing the error message in the orange bar that states some data couldn't be loaded (see attached image).

    The weight entered in my linked MyFitnessPal account does sync to Garmin Connect on the web. I just can't view that information from the mobile app on Windows. I even installed the UWP app on my desktop computer to make sure it wasn't a data connection issue with my phone, but the app on my desktop gives the same error message.


    same thing here- about two weeks now also. must just be the Windows 10 app, as weight data is available at the GC website.
  • But just a day later it has reverted to the same error again. There is clearly something that happens on at BT sync that doesn't on a cable sync (or vice versa).



    Mine seems to have been pretty much behaving itself lately. However, I've come to the conclusion that it's all to do with syncing to the Garmin web service rather than locally. If you watch what happens first thing in the morning when all the data starts off as null it won't update the display until the sync bar at the bottom completed. Once there is data already in the mobile then the figures update immediately - in fact I can get live updates as I walk. The progress bar still processes across the screen but the data doesn't update further. It's clear from this that the progress bar is indicating the progress of syncing with the Garmin cloud. If there is no data for the day it won't update the display until the cloud has updated and the app has read back from there. The times when the local display doesn't update is when I'm guessing the cloud is busy and doesn't respond fast enough or there is a poor data link.

    I'm not tracking weight at the moment so that would explain why I hadn't noticed that it wasn't updating. It could be that MyFitnessPal has changed the web service interface definition so that Garmin is having problems syncing with it.

  • I came here to see if anyone knew what is going on with this issue? I've been seeing this error message for what seems like 2 weeks, but maybe just the past week.

    Sometimes when I resume the GCM app, fields such as calories, steps, and sleep don't load correctly until I restart the app, but the error message seems to be specifically referring to the "weight" screen. That screen hasn't loaded any information since I first started seeing the error message in the orange bar that states some data couldn't be loaded (see attached image).

    The weight entered in my linked MyFitnessPal account does sync to Garmin Connect on the web. I just can't view that information from the mobile app on Windows. I even installed the UWP app on my desktop computer to make sure it wasn't a data connection issue with my phone, but the app on my desktop gives the same error message.


    I have the same issue with my Fenix x. I had never seen this with the Forerunner 920xt that I had.