Bug List (GCM 3.20, W10M Build 15228)

Hi guys,

Correction: the bugs listed are for W10M Build 15230

- Battery drain (big issue, GCM is using more than 50% of battery in background). To note here: the app is set to be "always allowed in background" in the the system settings, as otherwise notifications are not working reliably
- Bluetooth connection is lost way too often (also if phone is lying nearby)
- Watch is not reconnecting automatically when lost Bluetooth connection.
- When a notification is received on the phone and the watch is not connected, GCM reconnects to the watch but does not push the received notification.
- Sync is not reliable, especially when an app should be installed. With the recent release of GCM this seems to be even worse.
- Music controls do not work at all (always waiting for connection to the phone). If the music control widget opens and has connection, it is not possible to start music.
- Pairing issues with several devices
- GCM won't install on SD card

Post your bugs please.

Bye
  • I opted into the Fast Ring on my Lumia 950 specifically because one of the improvements for mobile on Build 15228 was improvement of Bluetooth connectivity with Garmin devices. For a while, I was seeing more frequent notifications pop up on my Vivoactive HR. I still occasionally get notifications with GCM 3.20, but I can no longer sync activity from the watch to the phone. I have to connect to my PC via USB every time I want to sync data.

    I even tried re-pairing the Bluetooth connection between the wearable and phone. There are no errors during sync. It just finished with a green bar that says the sync is complete, but no new data is updated.
  • Hi
    I installed the lasted WM10 build 15230.0 last night. GCM is version 3.20, Fenix 5s is running software version 4.10. Absolutely no improvements on my situation. My Fenix is not pairing or syncing with CGM at all. Only workaround is to sync via garmin express ( even that is not syncing up my latest updates - but that's another issue). Anyone else with the same set up experiencing this? Wondering if it is also a device issue and considering returning it as faulty


  • I have added this issue to the above list.

    Bye
  • Here is a bug. GCM 3.20 won't install onto an SD card in a W10M phone.

    Note I am still on 15063.483, but I suspect this bug is relevant to GCM 3.20 rather than W10M.

    I tried to upgrade to GCM 3.20. It kept failing, so I uninstalled GCM 3.19 and tried again. It still kept failing. So eventually I figured out that it wanted to install on the device, rather than onto the SD card, which was my current default setting. I changed my setting to install Apps onto the device, and 3.20 installed correctly.

    If Apps need to install onto the device and can't be installed onto the SD card, they are supposed to notify the user and ask if they can install onto the device instead. I have had several Apps do that since changing my settings. GCM 3.20 tries to download, probably even finishes the download, and then fails at install time, with the useless message "Something went wrong" and no more information. Yes, I reported the failure to Microsoft Store the first time.

    Garmin, get your act together. Any W10M App should have the ability to let the user know it needs to install onto the device. I think it is part of the requirements from Microsoft.


  • I have added this point to the above list.

    Bye