GCM V3.16.1.0 released

Lumia 950 release ring, GCM reinstalled without any tweak.

Connection is more stable, since this morning only lost connection twice. After a Lumia reboot the connection was reestablished
Notifications: OK/2 they usually work but with a delay.
Music controls: Usually they work as expected (play/pause, skip, volume) however sometimes they refuse to work;
Weather: No problem;
Find my phone: OK

Only have the new version installed for 9 hours so it's premature to say anything.
  • I am on the fast preview ring with my Lumia 950XL and for me notifications don't work at all. Also the connection is very fragile, but I guess this is because of the recent build in the fast ring. I hope Microsoft will release another build soon that fixes the Bluetooth connection issues...
  • WM : 15063
    Fenix HR 3
    GCM : 3.16.1

    Stability : Not good
    Weather : Ok
    Music : I have the control, but no effect
    Notification : Ko

    I hope it will working, one day ...
  • After putting GCM as always allowed in background, notifications started to work reliably (delay is still present) and a simple Bluetooth on off on the phone is enough to regain connection.

    However, I'm not a fast insider and by others reports it seems that in a few weeks, with the creator update, the problems will start again :mad:
  • After putting GCM as always allowed in background, notifications started to work reliably (delay is still present) and a simple Bluetooth on off on the phone is enough to regain connection.

    However, I'm not a fast insider and by others reports it seems that in a few weeks, with the creator update, the problems will start again :mad:


    This is interesting. What Windows 10 Mobile build are you currently using? I am on the fast ring and with the recent version (15063.2) notifications are only working if Garmin Connect Mobile app is in foreground. Immediately after putting it in background (with the same option set that you have also activated "allow always in background") the notifications are not delivered to the watch any more.

    I am still hoping that Garmin has another version of their app using the new Bluetooth APIs that Microsoft has build into the Creators Update, and that this app version will be released together with the major windows update. If not, then I guess we're screwed...
  • I'm on 14393.953

    I didn't update the app. I uninstalled and installed again. Also the app is consuming 30% in background and 3% in foreground
  • I'm on 14393.953

    I didn't update the app. I uninstalled and installed again.


    I also tried to uninstall/install again, no change.

    Thanks for the information!

    Bye
  • Odd behaviour

    I have a Lumia 840 and a Forerunner 630, all on latest updates (fast ring win 10). Yesterday I gave up trying to connect the watch to the phone as it could not find it in the Bluetooth setup routine.
    Then this morning, on starting the app, it went in to setup mode straight away and found the watch and all was looking good. Data synced and messages elated to my watch. Then I opened outlook on my phone and GCM shut off Bluetooth!! I then went back to GCM and it did not even have a link to my watch shown any more. I closed down the phone and restarted and it showed the phone again but it did not connect.
    I am certainly getting frustrated but still living in hope.
  • 950xl on latest fast ring won't pair

    Probably close to last RS2 build on my phone, as it ships real soon now.
    I reset GCM (no idea how to tell the build number), because sync was still failing and notifications weren't working. (Didn't work on RS1 either)
    Tried to pair the watch again. No luck.
    Tried shutting down the watch, didn't help.
    The silence from Garmin is deafening. I'd like updates. I'd even run beta software and report problems and send logs.
    I'm hoping we will get a new build of GCM soon that will fix all these issues.
    After an hour of trying, I finally got it to pair. Sync still fails about 20% in. No notifications.

    -RickH
  • I received the F5 on saturday, I had trouble connecting it with the L950 then somehow I was able to do it.
    I dont care that much for notification.
    But what I really need is the ability to transfer training thru the app on the phone, but it didnt work, while the steps, sleeping time and oHR seems to live-transfered properly.
    I'll try again tomorrow with the 1st swimming session and I hope it will work fine.
    Anyone got the issue?