This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

We are unable to add this device because our servers are unavailable at this time

Express is continually throwing this error when trying to add my FR 645. What I have done up to now:

Read many (older) thread here and elsewhere re similar issues and implemented the described recommendations
(Re)installed latest Express Version approx 5 times. (Total uninstall after each try, including Registry cleanup) Admin /Non-admin user.
Tried Boot Safemode + NW
Deleted .fit Activity files, Device.Fit + GarminDevice files on the watch. Cold restarted watch.
Used 3 different network connections. Check timezone, locale etc on both watch and notebook
Firewall disabled
Tried different USB ports
Reverted to older Express version, same error message

My CO300 and OR650 is connecting perfectly fine, every time.

Still error keeps on persisting. (It *think* it might have started when I downloaded the latest Express. Used to work fine)

Any pointers will be appreciated.