Is your BaseCamp 4.8.7 displaying 3D maps incorrectly?

I just upgraded to BaseCamp 4.8.7 on my MacBook Pro running Catalina (10.15.1). 

My 3D map no longer uses the entire area set aside for displaying the map. Rather, it is a smaller representation in the lower left part of the display area.

Is anyone else experiencing this? Any solutions?

  • Thank you I am away from computer but will see if I can find options (not very techno) and switch it 

  • Hi again 

    I have opened basecamp and cannot find options other than under Find and that doesn’t do it can you guide me to options 

    thanks Graham 

  • Not sure where it is on a mac, in Windows it's under Edit, Options, General

  • On the MAC to switch the database:

    BaseCamp>Preferences>Advanced> Then Newlib or Existing Lib or Default Location.

  • Hi MaGo77 thank you for this I have gone in their a few times but cannot see how I can then find the old routes or different database. when you click onto it it doesn't show any new database or route files. I think my problem was that garmin told me to go to library, then preferences, then drag garmin.basecamp.plist to the bin then empty bin when uninstalling and I am guessing that that was where the routes and waypoints were!! I have no idea whether this is the case. 

  • Your data isn't in that file.  The default for Mac is apparently

    /Users/[inlogname]/Library/Application Support/Garmin/BaseCamp/
    according to a quick Google serach
  • Thank you I have gone it there and it does show database where you have shown but this was the gamin folder that I was told to move to the trash and then empty trash so all I have is the stuff I have loaded since then, the rest has gone. Garmin look like they have got me to delete all the previous database data and it still hasn't solved the problem with 3d map.

    however I appreciate your time in help0ingh shame Garmin cant do the same.

  • Sorry to hear about the bum advice. Garmin "Support" is usually a crying shame. During an online chat a few years back, they had me trash a file off of my Upper Midwest Fishing Guide chip, and then later in the chat basically said "oopsie, my bad!" They did send me a free LakeVü chip for their error, but BaseCamp doesn't read that chip -- and never will, they tell me -- so I transferred everything to HomePort, unwittingly losing some of my track detail (time and elevation of individual track points). But now, HomePort doesn't work under MacOS Catalina -- and never will, they tell me -- so I got an old UMFG chip on eBay last week, and moved my data back to BaseCamp. (This time, I transferred tracks via an attached 64st which preserved the track data in its entirety.) Then upgraded the MacOS. 

    It shouldn't be this difficult.

  • Thank you 

    I so agree with you how come this is so difficult and why cannot they sort out the problem with the 3d map. why give such poor advice without considering the impact.

    I wish I had your knowledge and skill as most of what you said was above my brain power. I just hope that I cam get some of it back when I link my sat nav to basecamp and transfer them from the sat nav to laptop basecamp. 

    I will most likely use other software systems in future Garmin can stuff themselves. Although I have had trouble transferring from some systems to the sat nav but will find one that is better than the rubbish that garmin has made.

    take care Graham

  • If you have them on your satnav then you'll be able to transfer it all back.  I'm still not convinced the file you were asked to delete was your data file, but I'm not sufficiently clued up on macs to point you better to where it should be than I've already done.  On Windows you can track it down by searching for AllData.gdb and Folder.gfi